Fujitsu BIOS Flash

hardware
german

#1

Hallo,

ich habe gestern Mitternacht beim Kunden einen Fujitsu RX300S8 die Firmware auf die aktuelle Version geupdatet.

Der Grub- Loader startet, nach Auswahl des Kernels erhalte ich einen schwarzen Bildschirm für etwa 5 Sekunden, und der Server macht einen Reset (so als hätte ich den Reset- Knopf gedrückt). Und das in einer Endlosschleife.
Problem besteht mit Kernel 3.2 & 3.10, 2.6.32 lässt sich jedoch Problemlos booten.
Boote ich 3.10 im Wiederherstellungsmodus, so erhalte ich einen Kernel Panic:


Boote ich ein UCS3.2 Installations CD, so erhalte ich das gleich Problem beim der Auswahl des Installers im Boot- Loader.

Ein SLES (Kernel 3.0) & Windows lässt sich aber problemlos booten.
Gerne hätte ich auch noch versucht, ein Debian 7 Installer zu booten (hätte Kernel 3.2 gehabt, welcher bei UCS nicht funktioniert), leider ist in der Nacht der Download aber ständig abgebrochen, ein weiteres Testen wird die nächste Wochen/Monaten nicht möglich sein, da es eine Produktivmaschine ist.

Änderungen des Firmware- Flash:

[code]RIMERGY RX300 S8 BIOS changes:
Changes BIOS V4.6.5.4 R1.6.0 for D2939-B1x 12.02.2014

Changes and Problems fixed:

  • Disable POST Watchdog during BIOS Recovery Flash
  • Enable the Onboard Intel LAN PXE OPROMS if VIOM boot is enabled
  • Improve VIOM and Deployment boot combination
  • Improved BIOS Setup help text for the menus
    “Launch CSM” and “Launch PXE OpROM policy”
  • Resolved PCI Error event logs by PCI Express Advanced Error Reporting Control
  • Resolved ACPI errors reported by OS (SLES11 SP3)
  • Resolve missing selectable BIOS option LAN Port for UEFI PXE Boot
  • Resolved not working “Support password protected BIOS” feature
  • Resolved UEFI Mode operating system installations boot order
  • Resolved Error Reporting within memory initialization on the second CPU
  • Implementation for Emulex CNA adapters UEFI Boot Ready Feature
    New features
  • Add VIOM Boot Priority for Emulex CNA adapters
  • Implementation for Emulex CNA adapter UEFI Boot Ready Feature[/code]

Was weiß, was das Problem sein könnte??#
Habt ihr eigene Modifizierungen im 3er Kernel vorgenommen?

Derzeit läuft Maschine wieder mit dem alten Bios-Flash


#2

Hallo,

eventuell ist dass ähnlich/gleich dem Verhalten welches hier, ebenfalls mit Fujitsu Hardware, beschrieben wird: groups.google.com/forum/#!topic … BD_Ab1GWhM
Die Hinweise dort deuten darauf hin das Suse die entsprechenden Patches wieder aus ihrem Kernel entfernt hat, daher tritt das dort vermutlich nicht auf.

Ich habe dazu [bug]34446[/bug] angelegt.

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,

lt. Rückmeldung von Fujitsu sollte es möglich sein das System zu booten wenn GHES deaktiviert wird (Kernel Parameter ghes.disable=1).

[quote=“drivers/acpi/apei/ghes.c”]
Generic Hardware Error Source provides a way to report platform hardware errors (such as that from chipset). It works in so called “Firmware First” mode, that is, hardware errors are reported to firmware firstly, then reported to Linux by firmware. This way, some non-standard hardware error registers or non-standard hardware link can be checked by firmware to produce more hardware error information for Linux.[/quote]

Mit freundlichen Grüßen
Janis Meybohm