Fresh Install - Error installing any software

appcenter

#1

Hi!

I just set up a Test-Envirnonment with 1 PDC, 1 BDC and 3 Memberserver
For internet connection I have to use a proxy, which worked so far for the initial installation. On the mailserver for example kopano core installed correctly.
On another Memberserver I’d like to install e.g. OpenProject or some other software - which repeatedly failed with following error:

Ein Fehler ist aufgetreten: HTTPSConnectionPool(host=‘docker.software-univention.de’, port=443): Max retries exceeded with url: /v2/ucs-appbox-amd64/manifests/4.1-4 (Caused by NewConnectionError(’<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7f3c684e0810>: Failed to establish a new connection: [Errno 101] Das Netzwerk ist nicht erreichbar’,))

Thanks for any hint on this.

ucs 4.3.0-112

EDIT:
Already tried in UCR -> appcenter/docker/container/proxy/settings -> with values “yes”, “1”, “http://IP:Port” and restartet the whole server - no success.

No ideas on this?


#2

Hi,

do you have a proxy properly configured in UMC? (violett stuff, network settings, bottom - proxy).

What does
ucr dump| grep proxy
tell you (as root on the server with the issue)?


#3

Hi!

root@ucs-dc01:~# ucr dump | grep proxy
appcenter/docker/container/proxy/settings: yes
proxy/http: http://10.1.36.53:8080
proxy/https: http://10.1.36.53:8080
security/packetfilter/package/univention-bind/tcp/53/all/en: DNS proxy
security/packetfilter/package/univention-bind/udp/53/all/en: DNS proxy

#4

“dc01” points to a master server where you did the ucr dump. But you wrote the issue exists on member oder backup servers…

Could you do the ucr dump on the server which is not working properly? Or is the dc01 the member server?


#5

same thing an all servers - for example a memberserver:

root@ucs-app01:~# ucr dump | grep proxy
appcenter/docker/container/proxy/settings: yes
proxy/http: http://10.1.36.53:8080
proxy/https: http://10.1.36.53:8080

EDIT:
Installation via CLI works…