Free Radius fails to authenticate when using mac hw addresses

Hi All.
I am fighting with getting free radius to authenticate mac addresses from a cisco accesspoint.
Username and pass authentication works flawlessly, however when enabling mac verification, freeradius throws the following error in the log

Wed Feb 3 21:58:00 2021 : Auth: (10) Login incorrect (No Auth-Type found: rejecting the user via Post-Auth-Type = Reject): [f45c899205dd/f45c899205dd] (from client ap01 port 293 cli f45c.8992.05dd)

I have tried formatting all formatting options avalible to me.
The computer is in ucs with its mac address, and it has radius network access ticked.

Any suggestions will be greatly appriciated.

/Ras

Well … RTFM as they say. A colleague of mine pointed out that :

By default access to the network is allowed for every device (assuming the used user name has access). It can be restricted to only allow specific devices. This can be enabled by setting the Univention Configuration Registry variable radius/mac/whitelisting to true . When enabled, the device used to access the network is looked up via the LDAP attribute macAddress and the resulting computer object must have network access granted (either directly or via one of its groups), too.
(from https://docs.software-univention.de/manual-4.2.html#ip-config:radius:configuration:mac-filtering )