Fetchmail

mail
german

#1

Hey zusammen,

wir nutzen Zarafa in Kombination mit Fetchmail. Da der Parameter “bad-header” nicht standardgemäß auf “accept” steht würde ich das entweder gerne ändern oder zumindest konfigurieren. Ich weiß aber nicht wo ich es genau machen soll, die /etc/fetchmail wird ja über das python script erstellt. Wenn ich dort den Parameter ergänze

flist.append( "poll %s with proto %s auth password user '%s' there with password '%s' is '%s' here %s %s #UID='%s'\n" % \

um

flist.append( "poll %s bad-header accept with proto %s auth password user '%s' there with password '%s' is '%s' here %s %s #UID='%s'\n" % \

bekomme ich eine Fehlermeldung beim start des Dienstes. Hat jemand das bereits gelköst und kann mir da weiterhelfen?

Vielen Danke im voraus :smiley:
Werner


#2

Hallo,

wenn Sie das global setzen wollen, können Sie /etc/default/fetchmail bzw. das Template einfach erweitern:

OPTIONS=" --bad-header accept"

Mit freundlichen Grüßen
Janis Meybohm