Fetchmail und Globale IMAP Folder

mail
german

#1

Hallo,

wo muss man für einen Globalen IMAP Folder die Daten für fetchmail angeben? Bei einer “normalen” User eMail geht das ja beim Benutzer selber über die Erweiterten Einstellungen.


#2

Hallo,

Wenn der globale IMAP Folder bereits eine SMTP Adresse hat, an die man zustellen kann, sollte es schon ausreichen, einen Dummy-User anzulegen, die Fetchmail-Eigenschaften mit den Zugangsdaten des entfernten Servers zu füllen und dem Nutzer die betreffende SMTP-Adresse zu geben.

Wenn es allerdings um einen IMAP Folder geht, der erst mit Hilfe von Fetchmail eine zustellbare Adresse bekommen soll, müßte man in die fetchmailrc selbst eine ‘poll…’ Zeile hineinschreiben, in der der ‘mda’ Parameter vorkommt, und das müßte dann der Aufruf eines Programmes sein, das eine Mail an STDIN entgegennimmt und in den betreffenden IMAP Folder ablegt, etwa so:

poll <server> protocol IMAP username <username> password <password> is <irgendwer> here options mda <ein_programm_das_in_folder_zustellt>

Man kann davon ausgehen, daß die Fetchmail-Integration keine Zeilen in der /etc/fetchmailrc anfaßt, die nicht von ihm selbst angelegt wurden, die Unterscheidung wird durch das Suchen der Zeile mit

#UID='die_uid_des_nutzers'

getroffen.

viele Grüße
Frank Greif.


#3

Hallo,

ich verstehe die Teile “” und “mda <ein_programm_das_in_folder_zustellt>” nicht. was muss denn z.B. dort bei einem Folder "123@xyz.com" eingetragen werden und welches Programm kann man wie genau für die Zustellung verwenden?

Gruß,
Sören Wiechert


#4

Ich bräuchte hierzu mal einen Tipp. Ich habe einen IMAP-Ordner "shop@domain.com" angelegt. Damit funktioniert soweit auch alles, bis auf die Zustellung nach fetchmail. Ich versuche schon den ganzen Tag es hinzubekommen, komme aber nicht wirklich weiter.

Ich habe eine procmailrc angelegt

[code]# .procmailrc

routes incoming mail to appropriate mailboxes

PATH=/usr/bin:/usr/local/bin
MAILDIR=/var/spool/cyrus/mail/domain/w # all mailboxes are here
DEFAULT=/var/spool/cyrus/mail/domain/w/domain.com/s/user/me # default inbox
LOGFILE=/dev/null
SHELL=/bin/sh

shop@domain.com

:0:

  • ^(To).shop@domain.com
    /domain.com/s/Gemeinsame Ordner/Shop[/code]

In der fetchmailrc habe ich es so eingetragen

# shop@domain.com poll 'mail.domain.com' with proto pop3 no dns user 'shop@domain.com' there with password '#########' is 'me@domain.com' here nokeep ssl options mda 'procmail -f %F'

Es funktioniert aber nicht. Was ist falsch oder fehlt hier? Wie kann ich testen, ob procmail grundsätzlich korrekt installiert und lauffähig ist?


#5

Hallo Squeez,

Was ist es denn überhaupt für ein Imap-Server? Ich vermute mal Sie meinen Cyrus? Da brauchen Sie doch eigentlich Procmail gar nicht für diesen Fall, sondern Sie müßten für “<programm_das_in_folder_zustellt>” das Cyrus-Programm “deliver” verwenden. Abhängig von Ihrem Setup müßten Sie den Parameter “-m” so einstellen, daß es den Imap-Ordner benennt.

Der “” ist ein lokaler Unix-Nutzer. Fetchmail nimmt dessen Identität an, bevor es die Mail zustellt oder das Zustellprogramm ruft. Entweder Sie geben hier einen Systemuser an, unter dem ‘deliver’ funktionieren wird, oder Sie legen einen Nutzer an, den Sie ansonsten für nichts anderes verwenden.

Mit ein paar mehr Angaben über Ihr Setup und evtl. Zitaten aus den betreffenden Logfiles (Fehlermeldungen?) läßt es sich besser herausbekommen, worin das Problem besteht.

viele Grüße,
Frank Greif.