Fehlerhafter Domainbeitritt 92univention-management-console-web-server.int(gelöst)

german
join

#1

Hallo Zusammen,

ich komme leider nicht mehr weiter, ich habe jetzt 2. neue UCS Member-Server aufgesetzt, einmal mit einer alten 4.0 iso-Image und einmal mit einer neuen 4.2 iso-image.

Die Installation läuft mit der alten 4.0 komplett durch, doch bei den anschließenden Upgrade auf 4.2, läuft der Domäinbeitritt von dem Skript 92univention-management-console-web-server.int nicht durch.
Dies passiert mit der 4.2 Installation schon gleich bei der Installation, dort läuft das Skript schön nicht, auch ein nachträglicher Versuch geht immer schief.

Ich habe heraus gefunden, dass es sich um das SSO geht, beide Installationen haben wohl das Problem dass Sie angeblich den Host ucs-sso nicht finden.

Komischer Weise kann ich mich aber an der Weboberfläche anmelden auch mit dem Anmeldedaten vom Admin, also warum gibt UCS dann diese Fehlermeldung aus und wie könnte ich diesen Fehler beheben.

Ein Dritter Memberserver läuft ohne Probleme, dieser hat den Fehler nicht. Den Server habe ich früher installiert und ohne Probleme upgraden können. Komisch das dort alles geht.

Ich finde es aber noch komischer dass eine Neuinstallation schon garnicht geht, kennt noch jemand das Problem.

Ich bin um jede Hilfe dankbar.

Gruß
Schnoor


Keine Inhalte auf der Portal Seite
#2

Ist der Master denn schon auf 4.2? Der Master muß immer zuerst aktualisiert werden.

ucs-sso sollte aber auch schon seit 4.1 auflösbar sein:

nslookup ucs-sso

Falls dies nicht der Fall ist, kann es Sinn machen, das folgende Join-Script auf dem Master erneut auszuführen:

univention-run-join-scripts --force --run-scripts 91univention-saml.inst

#3

Hallo SIrTux,

danke für den Tip, hat geklappt damit. Aber sag mal warum muss ich es extra neu aufrufen, wenn ich einen neuen Server aufsetze, beim Join sollte doch alles automatisch gehen. Was macht dieses Script genau. Bin Neugierig :slight_smile:

Gruß
Carsten


#4

Das Script erstellt im wesentlichen einen SAML-IdP und fügt die IP zum DNS-Namen ucs-sso hinzu. Der DC Master und alle Backup DCs sind unter diesem Namen dann erreichbar.

Warum es diesen DNS-Namen nicht gab, weiß ich nicht. Aber ich vermute mal, daß er damals beim Upgrade auf UCS 4.1 angelegt wurde (denn der Status des Scriptes war ja anscheinend auf “Success”) und später irgendwie gelöscht wurde. Aber das wird man mangels Logs vermutlich nicht mehr nachvollziehen können.

Und ohne diesen DNS-Namen klappt dann natürlich die Einrrichtung der UMC auf den UCS-Servern als SAML SP nicht.

Falls du übrigens noch Backup DCs hast, würde ich das Join-Script auch da noch mal ausführen.


#5

Ok, Danke SIrTux, jetzt habe ich verstanden was das Script macht.
Nach dem ausführen, habe ich dann noch mal den Member-Server komplett neu installiert um zu sehen ob es jetzt direkt bei der Installation auch klappt und es funktioniert so wie ich es auch erwarte.

Einen Backup DC habe ich nicht, brauche ich zur Zeit nicht, da es nur alles für Testzwecke ist und es mein Privatvergnügen ist :slight_smile:

Gruß
Carsten