Fehler in fatal log-Datei - SIS Indexer

mail
german

#1

Hallo,

Falls jemand einmal über einen ähnliches Problem stolpert:

bei der Umstellung der IP mittels univention-system-setup-net werden die Einstellungen des Indexdiensts von Scalix nicht angepasst, womit dieser nicht mehr richtig funktioniert. Folglich häufen sich in der Log-Datei /var/opt/scalix/??/s/logs/fatal Fehlermeldungen folgender Art:

ERROR                   Indexer       (Indexer       ) Fri Feb  5 15:51:56 2010
[OM.DMON 3007] The SIS has been unable to process the Indexer's request. Details:
SIS could not handle this request.
Reason: 403 (Forbidden)
Indexer Service has discarded the message:
         User name: -Vorname- -Nachname- /-hostname-
         IndexId: c901a8c0-4b6a93a6-4b6c3083-584
         Attempted action: Delete item 00011028646a457b from folder 0001101cba016fad
Pid of logging process: 11562

Lösung: Anpassen der Parameter index.client.whitelist, search.client.whitelist und indexadmin.client.whitelist
in der Datei /var/opt/scalix/??/sis/sis.properties auf die neue IP.

So sollte der Abschnitt dann ungefähr aussehen (IP z.B.: 192.168.1.1):

...

# lock down requests from given IP addresses only
# default = empty
index.client.whitelist=192.168.1.1, 127.0.0.1

# lock down requests from given IP addresses only
# default = empty
search.client.whitelist=192.168.1.1, 127.0.0.1

# lock down requests to /admin/* from given IP addresses only.
# This includes http://<host>/sis which gets mapped to /sis/admin
# /admin/* is reserved for internal use by SCALIX support staff.
# default: empty
indexadmin.client.whitelist=192.168.1.1, 127.0.0.1

...

Und zuletzt Tomcat und Apache neustarten:

[code]# /etc/init.d/scalix-tomcat restart

/etc/init.d/apache2 restart[/code]

mfg,
Jürgen


#2

Hallo,

danke für den Hinweis. Ich habe dazu einen Bug angelegt, weil eigentlich bei der Änderung der IP-Adresse per System Setup die Konfigurationsdateien entsprechend angepasst werden sollten.

forge.univention.org/bugzilla/s … i?id=17702

Viele Grüße
Stefan Gohmann