Fehler bei Update von UCS 3.2

german

#1

Beim letzten Update von UCS auf 3.2-3 errata241 taucht ein Fehler im Log auf:

Processing triggers for python-support ...
/usr/lib/pymodules/python2.5/univention/ox/listener_tools.py:152: Warning: 'with' will become a reserved keyword in Python 2.6
Compiling /usr/lib/pymodules/python2.5/univention/ox/listener_tools.py ...
  File "/usr/lib/pymodules/python2.5/univention/ox/listener_tools.py", line 152
    with Exclusive(os.path.join(self.spool_dir, "lock.tmp")):
                 ^
SyntaxError: invalid syntax 

Kann der ignoriert werden?


#2

Hallo,

python2.5, das ist, nunja, nicht mehr auf frischen Installationen vorhanden. Sieht also ganz nach einem Überbleibsel aus. Ich würde mit “dpkg -S” nachsehen, zu welchem Paket die Datei gehört und dann schauen, ob es noch gebraucht wird bzw. warum es immer noch in der Konfiguration ist.

Viele Grüße,
Dirk Ahrnke


#3

Es ist tatsächlich beim Update auf UCS 3.2 als Überbleibsel geblieben.
Ich nahme an, daß eine Komponente die beim Update nicht entfernt wird, noch benötigt wird.
Nun ist es gelöscht und der Fehler ist weg.

Danke!