Failed to create DC Backup - Joining problem

german
join

#1

Hallo,

in einer reinen UCS-Domäne gibt es einen UCS-PDC (UCS 4.2.3). Beim Installieren eines zweiten UCS-Servers als Backup-DC scheitert der Domain-Join an der MAC-Adresse des (zweiten) Computers, der früher einmal als Client auf dem PDC registriert war, aber inzwischen im DNS gelöscht ist. Dennoch kommt die Meldung:

“failed to create DC Backup (1) [E: Object exists: (mac) 00:1f: …]”

Wie kann ich auf dem PDC die “alte” Mac-Adresse des “zu joinenden” Computers löschen?

Vielen Dank für Ihre Antwort.


#2

Huhu,

schauen Sie erst mal, welche Objekte die MAC-Adresse noch gesetzt haben: univention-ldapsearch 'macAddress=…' dn

Gruß
mosu


#3

Hallo Herr Bunkus,
vielen Dank für Ihre Rückfrage. Das Ergebnis ist:

root@ucs1:/# univention-ldapsearch 'macAddress=00:1f:c6:b3:e4:7d' dn
# extended LDIF
#
# LDAPv3
# base <dc="domainxxx",dc=local> (default) with scope subtree
# filter: macAddress=00:1f:c6:b3:e4:7d
# requesting: dn 
#

# COMPUTERNAME, computers, domainxxx.local
dn: cn=COMPUTERNAME,cn=computers,dc=domainxxx,dc=local

# search result
search: 3
result: 0 Success

# numResponses: 2
# numEntries: 1

COMPUTERNAME ist der Name des physikalischen Computers, der früher einmal als Client beim PDC registriert war.

Wie kann man die alten Einträge löschen?

Vielen Dank für Ihren Tip.

Gruß Jürgen


#4

Huhu,

Tipp: setzen Sie Ausgaben von Befehlen bitte in Code-Blöcke, indem Sie sie in zwei Zeilen einrahmen, in denen nur das hier steht: ``` Das macht die ganze Sache deutlich besser lesbar. Beispiel:

```

Hier die Ausgabe

```

Zum eigentlichen Problem: wenn Sie den Computer-Eintrag nicht mehr brauchen, dann löschen Sie den kompletten Computereintrag in der UMC (anmelden, »Geräte« → Computer anhaken → »Löschen«). Beim Neu-Joinen wird der eh neu angelegt. Wenn Sie den Computer-Eintrag noch brauchen (er also zu einer anderen Maschine gehört, die noch existiert und benutzt wird), dann einfach in der UMC den Computereintrag bearbeiten und in ihm die MAC-Adresse entfernen.

Gruß
mosu


#5

Hallo Herr Bunkus,

herzlichen Dank für Ihre Hilfe. In der Tat steckte der alte PC noch in “Geräte”. Nach Löschung dort ging der Join-Prozess auch weiter, blieb jedoch nach einiger Zeit erneut hängen.
Ich habe deshalb die Netzwerkkarte gewechselt und den Backup-DC neu installiert, was dann auch einwandfrei klappte.

Zum Abschluss bitte ich um Entschuldigung für die Verletzung der Etikette; ich werde versuchen, in Zukunft den Ausgabe-Code in “” zu setzen.

Gruß Jürgen


#6

Huhu,

keine Sorge, das hat nichts mit Etikette zu tun. Es ist schlicht nur hilfreich, weil dann die Ausgaben deutlich besser zu lesen sind (z.B. weil das Forum Zeichen wie # eben nicht als Einleitung einer Überschrift interpretiert, sondern sie 1:1 ausgibt). Dass man die Forensoftware und mögliche Formatierungshilfen nicht kennt, ist doch auch vollkommen verständlich. In der Richtung war’s gemeint: “so und so kann unser aller Arbeit etwas erleichtert werden”.

Gruß
mosu