FAILED: 26univention-samba.inst


#1

When I attempt to install Samba4 or Samba3 on my UCS Domain Slave Controllers I get when I run the join scripts.

FAILED: 26univention-samba.inst OR FAILED: 26univention-samba4.inst

Exact error:
26univention-samba.inst failed (exitcode: 1)

OR
26univention-samba4.inst failed (exitcode: 1)

I’ve uninstalled and reinstalled, still same error.


#2

Any one run into this error?


#3

Hi Brian,

could you provide the join.log (/var/log/univention/join.log)? At least the last part that covers the 26univention-samba[4].inst joinscript?


#4

Here are the join logs…from two UCS Slaves I attempted to join…both resulting in the same error…

ucs-4749 <-- Is a ESXi 5.5 VM
ucs-3076 <-- Is a Physical Server.

ucs-7502 <-- IS a physical Server that is the Master UCS Domain, which has UCS Active Directory (SAMBA4) already installed and working. Also has the Windows AD Connector installed in Synchronization of content data between an AD and this UCS domain mode, so that the are two separate domains, 1 WINDOWS AD and 1 UCS AD, but both share the same user/group object data.
join-ucs-4749.log (186 KB)
join-ucs-3076.log (257 KB)


#5

I could not see an error related to 26univention-samba4.inst in both logs.

The error for 26univention-samba.inst is:

RUNNING 26univention-samba.inst 2016-08-01 08:28:13.605209580-06:00 (in joinscript_init) ERROR: It is not possible to install a samba 3 domaincontroller into a samba 4 environment. EXITCODE=1


#6

This slave is being installed as a 2nd and 3rd UCS AD server (SAMBA4)for two remote sites. This is not being configured as a Windows File Server (SAMBA3)

The Master UCS Domain is the MASTER UCS AD Server (SAMBA4) for our UCS DOMAIN.

UCS AD was installed first and failed with:
FAILED: 26univention-samba4.inst
Exact error:
26univention-samba4.inst failed (exitcode: 1)

We then attempted just a windows fileserver install as a test, and it failed with:
FAILED: 26univention-samba.inst
Exact error:
26univention-samba.inst failed (exitcode: 1)

So on these two UCS Slaves, SAMBA4 or SAMBA3 will NOT install.

I can attempt the SAMBA4 install again and re-upload logs if that will help.


#7

I’ll try the installation again and upload logs again. It will be about a week though has I have some travel to do this week.