etc/Fetchmail ... nicht zu finden

mail
german

#1

Guten Abend zusammen.
Ich habe mich gestern erstmal mit diesem Paket auseinandergesetzt - auf dem Weg raus aus Microsofts Klauen.Bin begeistert wie glatt und kompakt alles klappt. Nur beim Thema Mailempfang und Versand harkt es. Habe Zafara installert, User sind da. Habe Fetchmail installiert und lse das ich dort Anpassungen vornehmen soll für die Poll usw. NUR unter User ROOT auf der Maschine finde ich den in etc\ nix zu fetchmail. Und die Modifikation die ich zu Postfix teilweise über das Webend und teilweise von Hand gemacht haben (SMTPRELAY) sorgen auch nicht für Versand. Ich stehe also noch recht am Anfang. Gibt es für einen NEwbie ein gutes Tutorial oder Tipps . Es wäre keine Problem nochmal drüber zu instalieren. Schön wenn ich “geholfen” würde.

Gruß

Achim


#2

Hallo,

haben Sie die betreffenden Punkte in der Dokumentation schon gefunden?
13.6. Integration von Fetchmail zum Abrufen von Mail von externen Postfächern
Der Teil mit dem SMTP-Relay kommt gleich danach.

Die vom fetchmail-Listenerskript (siehe 1.2.8. Listener/Notifier-Replikation erzeugte Konfiguration liegt in /etc/fetchmailrc. Falls diese wider Erwarten nicht erzeugt wird, was ich bei diesem überschaubaren Setup nicht erwarte, finden sich in 3.5. Listener/Notifier-Domänenreplikation Hinweise zur Fehlersuche.

Sowohl fetchmail als auch postfix protokollieren nach /var/log/mail.log. Die Zarafa-Komponenten haben ein eigenes Verzeichnis unter /var/log/zarafa. Wenn Sie mit den Dingen dort nicht klarkommen, können sie gern Teile davon, ggf. anonymisiert hier posten.

Viele Grüße,
Dirk Ahrnke


#3

Danke für die Antwort.

Die Passage hatte ich gefunden im Handbuch. Nur so richtig geholfen hat es nicht. Ich habe - es war noch nix wirklich wichtiges drauf - die Installation nochmal erneuert. Dann habe ich 1.) Fetchmail nachinstalliert über das Webend. Auf dem Rechern (root - Anmeldung) belibt es dabei - es gibt das Verzeichnis etc\fetchmail nicht. Ich habe dann in den Systemdienste gesehen, dass der Dienst auch nicht startet. Interner Modulfehler. Das ist alles nicht ganz so schön und für den Linux NB erstmal auch schwer zu durchschauen, wo ich jetzt am Besten hingreife um die Fehler einzugrenzen . ABER ich bin lernwillig. Wenn also Hinweise kommen b in ich sofort dabei

Gruß

Achim


#4

Das ist auch richtig so, daß es so ein Verzeichnis nicht gibt. Die Konfiguration landet in der Datei /etc/fetchmailrc. Und fetchmail startet auch erst dann, wenn Mailkonten im LDAP eingetragen wurde. Der erste Start muß danach manuell mit “/etc/init.d/fetchmail start” erfolgen.


#5

Und wenn es das nicht tun sollte dann hilft vielleicht ein

/etc/init.d/fetchmail debug-run weiter. Fetchmail hat so seine Probleme mit selbstsignierten SSL-Zertifikaten.