Error to Upgrade UCS 4.4.8 to UCS 5.0

Good night, I’m facing minor RPC issues with my UCS 4.4 crashing out of nowhere and I’ve decided to upgrade it to 5.0 to see if the issue resolves!

Previously it worked in master + backup mode, but the backup host started to fail and I ended up removing it, so much so that it no longer appears on the hosts. But now when I was updating by text mode with the command below the following error occurred:

univention-upgrade --ignoreterm --ignoressh

Please rerun command without --check argument to install.
31.10.21 23:45:55.516 DEBUG_INIT
**** Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–updateto’, ‘5.0-0’, ‘–ignoressh’, ‘–ignoreterm’]
Version=4.4
Patchlevel=8
starting net mode
—>DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 5.0-0
**** Downloading scripts at Sun Oct 31 23:45:58 2021
**** Starting actual update at Sun Oct 31 23:46:03 2021

Starting /tmp/tmpzHAf8s/preuplTpbM_.sh (dom out 31 23:46:03 -03 2021):

HINT:
Please check the release notes carefully BEFORE updating to UCS 5.0-0:
English version: https://docs.software-univention.de/release-notes-5.0-0-en.html
German version: https://docs.software-univention.de/release-notes-5.0-0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
Checking adc_mapping … OK
Checking adc_multiinstance_mapping … OK
Checking architecture … OK
Checking blocking_apps … Unable to cache apps
Unable to cache apps
OK
Checking default_master_packages … OK
Checking disk_space … OK
Checking failed_ldif … OK
Checking for_postgresql94 … OK
Checking hold_packages … OK
Checking kernel … OK
Checking kolab_schema … OK
Checking ldap_connection … OK
Checking ldap_schema … OK
Checking legacy_objects … OK
Checking master_version … OK
Checking md5_signature_is_used … OK
Checking min_version … OK
Checking minimum_ucs_version_of_all_systems_in_domain … FAIL
Checking old_packages … OK
Checking overwritten_umc_templates … OK
Checking ox_schema … OK
Checking package_status … OK
Checking python_ucr_template_compatibility … OK
Checking python_ucsschool_import_hook_compatibility … OK
Checking role_package_removed … OK
Checking samba_server_schannel … OK
Checking samba_tdb_size … OK
Checking slapd_on_member … OK
Checking ssh … OK
Checking system_date_too_old … OK
Checking system_role … OK
Checking term … OK
Checking tls_public_key_size … OK
Checking tls_public_key_size_ucs-sso … OK
Checking usr_mountpoint … OK
Checking valid_machine_credentials … OK

The system can not be updated to UCS 5.0 due to the following reasons:

minimum_ucs_version_of_all_systems_in_domain:
The following extensions are incompatible with UCS 5.0:
cn=64selfservice_userattributes,cn=ldapacl,cn=univention,dc=sagro,dc=local: [unspecified…unspecified)

Error: Update aborted by pre-update script of release 5.0-0

Does anyone know how I can fix this?

I only use Radius and Domain Controller Comptible in my UCS. image

It looks like you have an old record in LDAP. Try removing it with this command and re-run
the upgrade script after that.

# ldapdelete -x -D “cn=admin,$(ucr get ldap/base)” -y /etc/ldap.secret “64selfservice_userattributes,cn=ldapacl,cn=univention,dc=sagro,dc=loca”

Problem solved, for some reason the Self Service that had been installed previously gave a problem, I reinstalled the package again and managed to install it.

Removing the key via ldapdelete did not work. =(

Glad you resolved the issue. Did you use the command as shown? It has a typo in the end, unfortunately, “l” missing.