Erfahrungsbericht: SuperMicro X8DTL-3F

german

#1

Unser Thomas-Krenn Server SC825M (SuperMicro X8DTL-3F Mainboard Details: http://www.thomas-krenn.com/de/wiki/Supermicro_X8DTL-3F_Mainboard) zeigte beim ersten Installationsversuch mit UCS2.4 keine der beiden SAS-Festplatten an.
Auch ein “durchprobieren” aller möglichen megaraid modules per [ Module hinzufügen ] brachte keine Festplatten zum Vorschein.

Wir konnten die SAS-Platten für UCS über folgende Schritte “sichtbar” machen:

  • beim Installationsschritt “Hardwareerkennung” mit der Tastenkombination “Strg-Alt-F2” auf eine shell umschalten und folgendes eingeben:
modprobe mptsas	
echo "0x1000 0x0059" >/sys/bus/pci/drivers/mptsas/new_id		#dauert einen Moment, bis es "zurueck kommt"
dmesg|tail								#zeigt, ob die Platten erkannt wurden
  • mittels der Tastenkombination: “Strg-Alt-F1” wieder umschalten zur Univention-Installations-Prozedur und nach Univention-Anleitung weiter installieren bis zum Fenster mit der Meldung “Die Installation wurde erfolgreich abgeschlossen!”
  • jetzt mittels der Tastenkombination: “Strg-alt-F2” wieder auf eine shell schalten:
mount -o bind /dev /instmnt/dev
chroot /instmnt
echo mptsas>>/usr/share/initramfs-tools/modules
vi /usr/share/initramfs-tools/scripts/init-premount/fixmptsas4smX8DTL3F
  • Der Inhalt des scripts hat bei uns folgenden Inhalt:
#!/bin/sh -e
#
# 2011-04-12  leuenroth,SGBO  Fix mptsas module for LSI MegaRAID SAS 1068E
#                             on SuperMicro X8DTL-3F mainboard
myMODNAME="mptsas"

PREREQS="$myMODNAME"

prereqs() { echo "$PREREQS"; }

case "$1" in
    prereqs)
    prereqs
    exit 0
    ;;
esac

cat /proc/modules|grep "^${myMODNAME} " || modprobe $myMODNAME || {
        echo "$0: Warning: modprobe $myMODNAME failed."
}

echo "0x1000 0x0059" >/sys/bus/pci/drivers/${myMODNAME}/new_id
  • Nach dem editiern des scripts muss das Image für die Boot-Ramdisk neu gebaut werden:
chmod 755 /usr/share/initramfs-tools/scripts/init-premount/fixmptsas4smX8DTL3F
update-initramfs -u && ls -lart /boot
  • Zur überprüfung, ob das script auch in der Ramdisk angekommen ist, folgendes eingeben
zcat  /boot/initrd.img-2.6.32-ucs35-amd64| cpio -tiv| grep mptsas
  • grub’s menu.lst, grub’s device.map und /etc/fstab waren noch anzupassen, weil nach dem Rebbot bei uns die Boot-SAS-Platte als sda im kernel geführt wird - zum Installationszeitpunkt war sie sdb
vi /boot/grub/menu.lst

alt: sdb
neu: sda

vi  /boot/grub/device.map

alt: (hd0) /dev/sdb
neu: (hd0) /dev/sda
alt: (hd1) /dev/sdc
neu: (hd1) /dev/sdb

vi /etc/fstab

alt: sdb
neu: sda

  • mittels der Tastenkombination: "Strg-alt-F1 wieder umschalten zur Univention-Installations-Prozedur und sie abschließen.

  • Nach dem ersten erfolgreichen Booten von der ersten SAS-Platte ist noch die UniventionConfigurationRegistry zu korrigieren:

ucr set grub/boot=/dev/sda
ucr set grub/root=/dev/sda1
ucr set installer/device/0/name=/dev/sda1
ucr set installer/device/1/name=/dev/sda2

Seitdem funktioniert unser UCS tadellos :slight_smile:

@support: soweit “d’accord”? - gibt’s Hinweise / Verbesserungsvorshläge?


#2

Hallo,

vielen Dank für die ausführliche Dokumentation. Anscheinend werden unter den SuperMicro Mainboards für die LSI SAS Controller neue PCI-IDs vergeben, so dass das mptsas Modul den Controller nicht erkennen kann. Es gibt weitere ähnliche Fälle, unter anderem der folgende: comments.gmane.org/gmane.linux.scsi/63836

Mit UCS getestete Hardware wird von uns zusätzlich in einer Liste gepflegt in die wir Ihre Erfahrungen gerne aufnehmen würden. Wenn Sie daran Interesse haben, senden Sie uns zur Vervollständigung der Systeminformationen bitte ein “univention-system-info”-Archiv, z.B. über das UMC Modul “Systeminformationen” oder auch direkt per Mail an feedback@univention.de (gerne auch mit Referenz auf diesen Artikel).

Mit freundlichen Grüßen
Murat Odabas