Empty Management Console after Upgrade to 5.0

After upgrading from 4.4-8 to 5.0 and logging in with any administrative account the management console is empty. Only functions available are (depending on the broswer used)

Brave:

  • User Settings
  • Change Language
    Safari:
  • None, since not even the menu bar is displayed

Using the inspect function of Brave I can see the following messages in the JavaScript console:

Not showing empty umc:category:favorites
Not showing empty users
Not showing empty devices
Not showing empty domain
Not showing empty system
Not showing empty software
Not showing empty umc:category:umc

This looks like either the administrative accounts haven’t been added to the correct groups during the update or the groups used for displaying the management interface haven’t been properly populated.

Any hint on how to fix this?

Ok, found the source of my problem: When logging in via the start menu users get redirected to https://<ucs-host>/univention/umc/ - but the real target should now be https://<ucs-host>/univention/management/

At least using that link the UMC is visible again.

1 Like

I also have an all empty Management Console after upgrade.
If I got it right, https:///univention/management/ still serves the legacy management interface. This also works for me, but I don’t think it’s the proper solution.
The interface at https:///univention/umc/ shouldn’t be empty as well, should it?

Same over here on the primary node. Using /univention/umc or /univention/management makes no difference over here. On the backup node the upgrade was ok and the management console seems to work. Alas, I haven’t rebootet the backup yet, so its UI is a mixture of old theme and new (dark) theme, but at least I can manage users and such from the backup node where the primary node is showing just empty pages.

Edited:
After some 6 more hours waiting, it seems now to work and I’m able to click on eg Users or Computers and actually see some content and not only an empty page anymore. No idea if there are some background jobs that took their time or so, but for now I’m somewhat happy everything seems to work again. :slight_smile:

I managed to upgrade my home server to UCS 5. It seems to have been successful, but I also have portal issues. All my existing apps seem to be working so I think I’m fine to stick with it for a while, but none of the management functions are visible in the portal. I have to manually go to /univention/management to get to the settings. There doesn’t appear to be a way to get there from the portal after log in as there was in version 4.

Maybe if I wait long enough it will show up, but I’ve tried different browsers so I don’t think it’s just a cache problem.

I think the problems can be related to the browser cache. I experienced a similar problem and started the Browser development tools, which automatically disable all caching. After that it worked. So clearing your browser cache may help to fix issues.

1 Like

This is exactly what happened to me. Thank you for your post. I have found no other mention anywhere, nor was any UCS staff able to identify this. I now have access to Administrator functions I have been trying to get back for almost 2 full weeks. I cleared my browser cache multiple times and it never showed up until I added management to URL. Thank you for your post

Hi there,
we had the same problem with the GUI, we solved it by installing the update for Microsoft .NET Framework 3.5 and 4.8, after that it worked fine again

I found the problem on my UCS 5 system. For some reason the checkbox at the bottom of the edit panel that says something like display only when not logged in was checked.

I edited the portal and then clicked to edit the management button. I unchecked the checkbox and saved my portal edits. Now the button shows on the first screen and I can just click it to get to the management settings. Simple fix for something I didn’t even know was there. Not sure how that option was enabled during the upgrade, but that appears to have been what happened.

Same here, at a fresh install of 5.0.
It all worked well for some time. But now:
/univention/umc/ is empty after a server reboot.
/univention/management/ is working