Einstellen von Speed & Duplex der Netzwerkkarten bei UCS3

german

#1

Hallo,

ich nutze bei meinem UCS3-System zwei Netzwerkkarten für die Anbindung älterer Netzwerkdevices.
Hierzu ist es notwendig, die Speed/Duplex-Settings der NICs fest auf 10MBit FullDuplex zu stellen.
Bei meinem alten UCS 2.4, der als Gast auf einem ESXi lief, war das kein Problem, hier konnte ich die Einstellungen auf dem ESXi vornehmen, und damit lief
es auch sehr zuverlässig.
UCS3 läuft nun direkt auf der (identischen) Hardware, folglich muss ich auf ethtool und mii-tool für diesen Zweck zurückgreifen.
Ethtool ist standardmäßig nicht installiert, und werden bei einem apt get ethtool auch nicht gefunden.

Die mii-tools sind installiert und unterstützen scheinbar auch die (onboard-) NICs, allerdings führt ein

mii-tool -F 10baseT-FD eth0 nicht zum Erfolg, der Datendurchsatz geht dann immer noch extrem stockend, wie auch bei Autonegotiation.

Gibt es ein UCS-Tool, mit dem diese Einstellungen ebenfalls vorgenommen werden können, oder kann (wie?) ethtool installiert werden?


#2

Hallo ich nehme mal an du hast nicht wirklich diesen Befehl eingebeben :wink:

apt get ethtool

Ist die UCR-Variable repository/online/unmaintained auf yes bzw. enabled gesetzt?


#3

[quote=“SirTux”]Hallo ich nehme mal an du hast nicht wirklich diesen Befehl eingebeben :wink:

apt get ethtool

Stimmt… :wink:

apt-get install ethtool

sollte es lauten…

[quote=“SirTux”]
Ist die UCR-Variable repository/online/unmaintained auf yes bzw. enabled gesetzt?[/quote]

Müsste ich nochmal überprüfen…


#4

Anbei noch ein Nachtrag: Die genutzten Netzwerkkarten sind Realtek RTL8111B - leider…
Auch bei ESXi hatte ich anfangs Probleme damit, bis ich aktuelle Treiber (von Realtek) dafür eingesetzt habe.
Ich werde heute nochmal versuchen, die ethtools zu installieren und berichten.

Kann ansonsten jemand berichten, welches Modul bei UCS3 (Debian Squeeze) für die RTL8111B genutzt wird? r8111, r8168 oder r8169?
(Bin momentan unterwegs und kann das nicht prüfen…)


#5

ucr set repository/online/unmaintained="yes" apt-get update apt-get install ethtool

und anschließendes

ethtool -s eth0 autoneg off speed 10 duplex full

hat soweit erstmal funktioniert…
Flowcontrol (“rx off”) lässt sich allerdings nicht abschalten (wohl von NIC/Treiber nicht unterstützt)

Als Treiber wird r8169 geladen.

#ethtool -i eth0 driver: r8169 version: 2.3LK-NAPI firmware-version: N/A bus-info: 0000:03:00.0

Nach den ersten Tests läuft das ganze damit stabil :slight_smile:


#6

So, jetzt besteht nur noch das Problem, dass die Einstellungen nur bis zum Reboot halten - sie müssten also entsprechend in die Interfaces-Datei geschrieben werden, wie
hier empfohlen: http://wiki.debian.org/NetworkConfiguration#Setting_the_speed_and_duplex.
Allerdings sollte die /etc/network/interfaces nicht manuell bearbeitet werden, und die entsprechende UCS-Datei (/etc/univention/templates/files/etc/interfaces) ist ja ein Template.
An welcher Stelle kann ich also die entsprechenden Änderungen dauerhaft vornehmen?
Oder gibt es dazu eine UCR-Variable?


#7

Hm, Lösung wahrscheinlich gefunden:

 ucr set interfaces/eth0/options/1='up sleep 5; ethtool -s eth0 autoneg off speed 10 duplex full'

Der passende Anstoss kam durch https://forge.univention.org/bugzilla/show_bug.cgi?id=20701