Einspielen von Hotfix funktioniert nicht?

german

#1

Beim Einspielen des aktuellen Samba Hotfix bin ich nicht sicher ob das Hotfix installiert wurde:

# wget http://download.univention.de/updates/security/ucs-security-2.2-0.hotfixes_091009-i386.tgz
# univention-security-update local --file ucs-security-2.2-0.hotfixes_091009-i386.tgz
# univention-actualise --dist-upgrade 
Running apt-get update
Setting pkgdb/scan
File: /etc/apt/apt.conf.d/60invoke
Dist-upgrading system
E: failed to upgrade
Setting pkgdb/scan
File: /etc/apt/apt.conf.d/60invoke
Setting pkgdb/scan
File: /etc/apt/apt.conf.d/60invoke
Reading package lists... Done
Building dependency tree... Done

Die Fehlermeldung wurde hier ([url]Univention-actualise auf 2.2.0.3 schlägt fehl (?)]) zwar schon erklärt, aber wo kann ich nachvollziehen das die aktualisierten Dateien installiert wurden?

Als Version wird ausgegeben:

# ucr search ^version
version/patchlevel: 2
version/releasename: copper beech
version/security-patchlevel: 3
version/version: 2.2

Mit freundlichen Grüßen,

Mario Minati


#2

Hallo,

um die Installation der im Hotfix angekündigten Pakete zu verifizieren, können Sie die unter apt.univention.de/2.2/maintained/hotfixes/* angegebenen Paketversionen mit denen auf Ihrem lokalen System vergleichen.

Fragen Sie die Versionsnummer des aktuell installierten Samba-Pakets über das “Software-Management”-Modul der Univention-Management-Console ab:

Installierte Version:  2:3.2.8-1.386.200910081351

Alternativ liefert der Befehl “dpkg -l samba” die gleichen Informationen. Eine entsprechende ausgabe sollte auf Ihrem System wie folgt aussehen:

Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Säubern/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/Fehlgeschl. Konf./Halb install.
|/ Fehler?=(kein)/Halten/R=Neuinst notw/X=beide (Status, Fehler: GROSS=schlecht)
||/ Name                              Version                           Beschreibung
+++-=================================-=================================-==================================================================================
ii  samba                             3.2.8-1.386.200910081351         a LanManager-like file and printer server for Unix

Die aktuell im Hotfix verfügbaren Version ist “samba_3.2.8-1.386.200910081351_amd64.deb”. Somit ist in diesem Beispiel der Samba-Hotfix installiert.

Mit freundlichen Grüßen
Janis Meybohm