ecoDMS Setup auf Memberserver

german
ucs-4-2

#1

Ich würde gerne ecoDMS auf eine UCS-Memberserver installieren. Ist das jemandem schon mal geglückt? Ich habe nämlich so einige nicht auflösbare Abhängigkeiten. Gut, ich verstehe auch nicht wie die Serverkomponente libqt oder gksu brauchen kann, aber ich muss ja nicht alles verstehen. Ich bekomme folgendes:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 ecodmsserver : Hängt ab von: libqt5core5a ist aber nicht installierbar
                Hängt ab von: libqt5gui5 ist aber nicht installierbar
                Hängt ab von: libqt5sql5 ist aber nicht installierbar
                Hängt ab von: libqt5xml5 ist aber nicht installierbar
                Hängt ab von: libqt5widgets5 ist aber nicht installierbar
                Hängt ab von: libqt5network5 ist aber nicht installierbar
                Hängt ab von: libqt5sql5-psql ist aber nicht installierbar
                Hängt ab von: oracle-java8-unlimited-jce-policy ist aber nicht installierbar oder
                               openjdk-8-jre soll aber nicht installiert werden
                Hängt ab von: gksu ist aber nicht installierbar oder
                               kdesudo ist aber nicht installierbar
                Hängt ab von: haveged ist aber nicht installierbar

#2

Wieder mal ein Selbstgespräch :slight_smile:

Ich habe es dann doch einfach auf einem Debian 9 installiert. Die LDAP-Anbindung ist allerdings etwas eigenwillig:

https://wiki.mhcsoftware.de/ecodms


#3

Huhu,

Bis auf oracle-java8-unlimited-jce-policy sind alle Pakete im unmaintained-Repository verfügbar. Als Alternative zum letztgenannten ist openjdk-8-jre aufgeführt, aber auch das gibt es noch nicht — dafür aber openjdk-7-jdk. Sprich das ecoDMS-Paket scheint explizit für Debian 9 gebaut zu sein, nicht für Debian 8 (und UCS 4.2 basiert noch auf Debian 8; erst das demnächst herauskommende UCS 4.3 wird auf Debian 9 basieren).

Gruß
mosu


#4

Es gibt ein Repository für Debian 8 und für Debian 9. Auf das mit dem “unmaintained” bin ich vorhin auch gestossen. Da ich im Moment so wie so nur damit experimentiere werde ich das noch mal neu mache und so versuchen. Bei den wesentlichen Sachen weiss ich jetzt ja wie es geht. Falls es dich interessiert, Seite 38:

https://www.ecodms.de/index.php/de/component/jdownloads/send/50-handbuecher-16-09-de/131-installation

Ich teste das und berichte wieder …


#5

Mit den “unmaintained” Repository geht es dann problemlos. Man muss nur noch ein paar Sachen beachten:

https://wiki.mhcsoftware.de/ecodms