Dymo Labelwriter Drucker

german
cups

#1

Moin,

ich hab mehrere Probleme mit einem Dymo LabelWriter Drucker unter Linux.

Ausgangslage
[ul]
[li] Ich habe die Druckertreiber von Dymo Heruntergeladen und installiert.[/li]
[li] Ich habe in der LDAP unter dn: cn=printeruris,cn=cups,cn=univention,dc=anders,dc=hamburg eine printerURI usb:// ergänzt[/li]
[li] Ich habe die PPD Datei unter dn: cn=DYMO,cn=cups,cn=univention,dc=anders,dc=hamburg ergänzt[/li]
[li] Ich habe den Drucker eingerichtet.[/li][/ul]

Das lokale Drucker auf dem Rechner selbst funktioniert.
Das Drucken via Cups aus dem Netzwerk auf andere Drucker geht.

Problem 1: Entferntes Drucker
Das entfernte Drucken von einem anderen Rechner über Cups funktioniert nicht. Die Fehlermeldung ist:

Ich habe daraufhin cups gestoppt, in der /etc/cups/printers.conf die Zeichenkette: “Shared No” durch “Shared Yes” geändert und cups neu gestartet. Selbe Resultat.

Ich habe über die Cups Weboberfläche (Port 631) Sharing enabled. -> Selbe Resultat

Problem 2: Drucker URL ändert sich manchmal

Die Durcker URL ändert sich.

Nach einiger Zeit (?) ändert sich die Drucker URL von
DeviceURI usb://DYMO/LabelWriter%20450%20Turbo?serial=15….

zu:

DeviceURI usb:/DYMO/LabelWriter%20450%20Turbo?serial=15…

Ändere ich etwas im LDAP Drucker Objekt wird über den Listener der Drucker neu geschrieben und die URL ist wieder okay.

Problem 3: Internetbriefmarke wird nur halb gedruckt

Die Internetbriefmarke der Deutschen Post erscheint nur zur Hälfte auf dem Etikett, obwohl das PDF (von den Maßen) okay aussieht. Andere PDFs werden richtig gedruckt.

Workaround:

[quote]convert -density 300 Downloads/Briefmarken.1Stk.08.03.2017_1532.pdf -background white -alpha remove Briefmarke.png
lp -d dymo450 -o PageSize=w252h116.1 Briefmarke.png
[/quote]

Sachdienliche Hinweise erbeten.


#2

Nachtrag Problem 3 konnte ich inzwischen lösen.

Es fehlte ein -o landscape Also folgendes geht:

lp -d dymo450 -o landscape -o PageSize=w118h252
Briefmarken.1Stk.12.04.2017_1231.pdf