Drbd, kernel != userland versions

german

#1

Wir haben gerade bei einem Kunden seit 1.5 Stunden das Problem, dass sich eine DRDB-Resource nicht mehr verbinden läßt.

[code]root@s-vucs02:~# drbdadm connect vm_s-vucs03
DRBD module version: 8.4.3
userland version: 8.4.4

root@s-vucs02:~# drbd-overview

7:vm_s-mwin01/0 Connected Secondary/Primary UpToDate/UpToDate A r-----
10:vm_s-vucs06/0 Connected Secondary/Primary UpToDate/UpToDate A r-----
11:vm_s-vucs03/0 WFConnection Secondary/Unknown Outdated/DUnknown A r-----
12:vm_s-vucs04/0 Connected Secondary/Primary UpToDate/UpToDate A r-----
13:vm_s-vucs05/0 Connected Secondary/Primary UpToDate/UpToDate A r-----

root@s-vucs01:~# drbd-overview

10:vm_s-vucs06/0 Connected Primary/Secondary UpToDate/UpToDate A r-----
11:vm_s-vucs03/0 StandAlone Primary/Unknown UpToDate/DUnknown r-----
13:vm_s-vucs05/0 Connected Primary/Secondary UpToDate/UpToDate A r-----
…[/code]

Ich habe einen alten Bug-Report von Mai 2013 gelesen, der als Closed/Fixed markiert ist.
Gibt es diesen Bug noch?

Versionen:

[code]root@s-vucs02:~# ucr dump | grep version
repository/online/component/3.1-0-errata/version: 3.1
repository/online/component/3.1-1-errata/version: 3.1
repository/online/component/3.2-0-errata/version: 3.2
repository/online/component/3.2-1-errata/version: 3.2
repository/online/component/3.2-2-errata/version: 3.2
repository/online/component/3.2-3-errata/version: 3.2
repository/online/component/drbd_20130516/version: current
update/umc/nextversion: true
version/erratalevel: 185
version/patchlevel: 3
version/releasename: Borgfeld
version/version: 3.2

root@s-vucs01:~# ucr dump | grep version
repository/online/component/3.1-0-errata/version: 3.1
repository/online/component/3.1-1-errata/version: 3.1
repository/online/component/3.2-0-errata/version: 3.2
repository/online/component/3.2-1-errata/version: 3.2
repository/online/component/3.2-2-errata/version: 3.2
repository/online/component/3.2-3-errata/version: 3.2
repository/online/component/drbd_20130516/version: current
update/umc/nextversion: true
version/erratalevel: 185
version/patchlevel: 3
version/releasename: Borgfeld
version/security-patchlevel: 8
version/version: 3.2[/code]


Drbd.ko stürzt ab
#2

Ich habe es selbst folgendermaßen gelöst:

Auf der Maschine mit der Fehlermeldung:
drbdadm disconnect vm_res

Auf dem anderen Node:
drbdadm connect vm_res

Danach hat er wieder begonnen zu syncen und zeigte danach ein schönes

11:vm_s-vucs03/0     Connected Primary/Secondary UpToDate/UpToDate A r-----

Also zusammengefasst:
Wenn der Fehler auf einem Node auftritt, dort einfach disconnecten und am anderen connecten und hoffen. :slight_smile:


#3

Hallo,

nur kurz dazu:

[quote=“roland.gsell”]Ich habe einen alten Bug-Report von Mai 2013 gelesen, der als Closed/Fixed markiert ist.
Gibt es diesen Bug noch?[/quote]

Bitte den Bug verlinken, dann fällt die Antwort ggf. etwas leichter.

Ansonsten: schön dass es erstmal wieder geht. Definierte Reaktionszeiten bei “system almost down” schaffen wir im Forum nicht.

Viele Grüße,
Dirk Ahrnke