DNS Slave/ Forward Zones - Wie?

german

#1

Hallo,

den Artikel im Wikihabe ich gelesen und auf dem Domain Master umgesetzt.
Die forward-zone ist eingeerichtet und wird auch entsprechend bedient:

[code]#/etc/bind/local.conf

add local zones here

zone “evs-nb.de” {
type forward;
forwarders { 192.168.230.2; 192.168.230.5; 192.168.231.6;};
};[/code]

[code]root@dc:/etc/bind# dig host.domain.de

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> host.domain.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29898
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 6, ADDITIONAL: 5

;; QUESTION SECTION:
;host.domain.de. IN A

;; ANSWER SECTION:
host.domain.de. 53 IN A 192.168.230.1

;; AUTHORITY SECTION:
domain.de. 53 IN NS p1.domain.de
domain.de. 53 IN NS p2.domain.de
domain.de. 53 IN NS p3.domain.de
domain.de. 53 IN NS p4.domain.de

;; ADDITIONAL SECTION:
p1.domain.de. 104 IN A 192.168.230.2
p1.domain.de. 126 IN A 192.168.230.5
p1.domain.de. 180 IN A 192.168.231.6
p1.domain.de. 126 IN A 192.168.232.9

;; Query time: 0 msec
;; SERVER: 192.168.230.10#53(192.168.230.2)
;; WHEN: Sun Dec 4 19:13:20 2016
;; MSG SIZE rcvd: 240[/code]

Soweit alles gut.

Nun möchte ich das gleiche auf dem “Domaincontroller Backup” haben. Aber zum Einen nutzt der kein samba4 als Backend (warum eigentlich nicht?)

root@bu2:~# ucr get dns/backend ldap

Und des Weiteren kann ich in die local.conf eintragen was ich will. Keines bringt mir die Slave-Zone!

Wie kriege ich das auf dem Backup hin?

Danke!

/KNEBB


#2

Ist auf dem Backup Samba4 installiert? Auch auf einem Samba4 Controller kann das Backend auf LDAP gestellt sein, da sich das Suchverhalten in beiden Einstellungen ändert und LDAP weniger “teuer” in der Ressourcen Allokation ist, kommt es vor, dass das so eingestellt wird. Aber ohne Samba4 macht es natürlich keinen Sinn das Backend auf Samba4 zu stellen.


#3

Hallo,

nein, Samba4 war noch nicht installiert. Habe ich jetz via UMC nachgeholt. dennoch steht die Variable weiterhin auf “ldap”.

Bleibt die Frage, warum das entscheidend ist für eine Slave-Zone?
Und natüprlich die Frage ob und ggf. wie ich das umstelle auf samba4?

/KNEBB


#4

Das setzen der Variable geschieht folgendermaßen:

# ucr set dns/backend=samba4

Geben Sie gern Bescheid ob Sie damit nun Erfolg haben.


#5

Hallo,

nach dem Setzen der Registry (wobei es mir eher weniger um den reinen Befehl ging, sondern um evtl. Auswirkungen, Vorteile, NAchteile… :)), wird nun die neue Zone auch als Forward genutzt.

Soweit prima.

  1. Gibt es irgendwo eine Doku, die den Unterschied im Backend beschreibt?
  2. Kann man auch Slave Zonen einrichten?

Danke!

/KNEBB


#6

Zum Beispiel hier im Performance Guide: https://docs.software-univention.de/performance-guide-4.1.html#bind

Muss jetzt dumm fragen: funktioniert die Einrichtung nun nach dem Wiki Artikel mit Subdomains nicht? Wenn nicht, wo hakt es? Irgendwelche Fehler?


#7

Zum Beispiel hier im Performance Guide: https://docs.software-univention.de/performance-guide-4.1.html#bind
[/quote]
Ausschließlich Performanz-Gründe?

Funktioniert, wollte nur gerne Slave-Zonen nutzen, da die Abfragen via VPN dann etwas weniger werden…zu Beginn ein Zonetransfer und dann nur noch wenn sich etwas ändert. Mit der forward-Zone wird ja JEDER Request an den (remote) Server weitergeleitet.


#8

Haben Sie diesen Thread bereits gesehen? Hier geht es um ein ähnliches oder sogar gleiches Thema: [url]NS Records und Slave only DNS Zonen]

Zu den verschiedenen Backends: Sie haben mit dem Backend Samba4 etwas mehr Konfigurationsmöglichkeiten (unter anderem per RSAT Tools über Windows). Ansonsten sind es einfach 2 unterschiedliche Verzeichnisdienste, die dafür verwendet werden.


#9

Hi,

ja, den Thread kannte ich, pass aber nicht wirklich. Dort will man ja eine getrennte Subdomain machen.

Ich brauche einfach nur einen Slave. Habe nun in der /etc/univention/local.conf.samba4 einfach anstelle einer Forward-Konfig eine slave eingefügt:

# add local zones here
zone "e*****.de" {
        type slave;
        masters { 192.168.**.**; 192.168.**.**; 192.168.**.**;};
        file "e****.zone";
};

Und es funktioniert. Irgendwie hatte ich das vorher schon probiert, aber jetzt hat es geklappt.

/KNEBB