DNS not working among other errors after updating

Hey guys.

After an update and a reboot, the server started having some issues. The main one was the inability to get new machines on the domain due to a DNS error. When trying nslookup, host and even trying to force a dns update, I saw that it does not find the server, as in the errors below.

[2023/06/20 16:22:46.439658,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate: Traceback (most recent call last):
[2023/06/20 16:22:46.439692,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 914, in <module>
[2023/06/20 16:22:46.439699,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     creds = get_credentials(lp)
[2023/06/20 16:22:46.439703,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 214, in get_credentials
[2023/06/20 16:22:46.439707,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     get_krb5_rw_dns_server(creds, sub_vars['DNSDOMAIN'] + '.')
[2023/06/20 16:22:46.439711,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 173, in get_krb5_rw_dns_server
[2023/06/20 16:22:46.439715,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     rw_dns_servers = get_possible_rw_dns_server(creds, domain)
[2023/06/20 16:22:46.439719,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 152, in get_possible_rw_dns_server
[2023/06/20 16:22:46.439729,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     ans_soa = check_one_dns_name(domain, 'SOA')
[2023/06/20 16:22:46.439733,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 308, in check_one_dns_name
[2023/06/20 16:22:46.439736,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     return resolver.resolve(name, name_type)
[2023/06/20 16:22:46.439740,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:   File "/usr/lib/python3/dist-packages/dns/resolver.py", line 1002, in query
[2023/06/20 16:22:46.439746,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate:     raise NXDOMAIN(qnames=qnames_to_try, responses=nxdomain_responses)
[2023/06/20 16:22:46.439749,  0, pid=1357] ../../lib/util/util_runcmd.c:355(samba_runcmd_io_handler)
  /usr/sbin/samba_dnsupdate: dns.resolver.NXDOMAIN: The DNS query name does not exist: example.local.
[2023/06/20 16:22:46.455607,  0, pid=1357] ../../source4/dsdb/dns/dns_update.c:86(dnsupdate_nameupdate_done)
  dnsupdate_nameupdate_done: Failed DNS update with exit code 1

host -al $(dnsdomainname):

Trying "example.local"
Host example.local not found: 9(NOTAUTH)
; Transfer failed.

nslookup example.local:


** server can't find example.local: NXDOMAIN

If a run samba_upgradedns --dns-backend=BIND9_DLZ:

Reading domain information
DNS accounts already exist
No zone file /var/lib/samba/bind-dns/dns/EXAMPLE.LOCAL.zone (normal)
DNS partitions already exist
dns-srvucs account already exists
See /var/lib/samba/bind-dns/named.conf for an example configuration include file for BIND
and /var/lib/samba/bind-dns/named.txt for further documentation required for secure DNS updates
Finished upgrading DNS

In addition, the System Diagnostics also gives some errors.

This package error is from lvm2, after running dpkg --configure -a:

Configurando lvm2 (2.03.02-3) ...
update-initramfs: deferring update (trigger activated)
Failed to restart lvm2-lvmpolld.service: Unit lvm2-lvmpolld.socket is masked.
invoke-rc.d: initscript lvm2-lvmpolld, action "restart" failed.
● lvm2-lvmpolld.service - LVM2 poll daemon
   Loaded: loaded (/lib/systemd/system/lvm2-lvmpolld.service; static; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:lvmpolld(8)
dpkg: erro ao processar o pacote lvm2 (--configure):
 o subprocesso instalado, do pacote lvm2, o script post-installation retornou erro do status de saída 1
A processar 'triggers' para initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-24-amd64
Erros foram encontrados durante o processamento de:

Any idea how to solve these problems? At least the DNS one…


Do you try the fix button for “reset Kerberos/KDC to” ?
This could be fix your DNS issue.

I managed to solve. It turned out that the problem was the same as this topic Installing openntpd seems to break the installation - UCS - Univention Corporate Server - Univention Help. I reinstalled the packages and the problem was solved. I also solved the lvm2 problem and at the moment, everything is working. Thanks