DNS Forwarding

german

#1

Es ist lieber um keine DNS Weiterleitung in UCS zu haben. BIND program ist ziemlich leicht zu konfigurieren um
die Lösung den unbekannten Namen selber zu machen. Es genügt in die Datei “named.conf” die folgende Befehle
zu schreiben:
zone “.” {
type hint;
file “/etc/root.hint”;
};

und die passende Datei “root.hint” zu installieren.

Leider mit UCS musst Template benutzt sein. Es ist nicht völlig klar wie man diese Template modifizieren
um der gleiche Zweck zu erreichen.

Eine andere interresante Veränderung der Bind Konfiguration würde sein eine Erlaubnis um alle Daten in die BIND DatenBanken
zu übertragen (DNS Zone transfer). Diese Einstellung ist leicht in Bind zu machen und schwer in die Template zu beschreiben.
Diese Übertragung ist sehr nützlich um die Befehle “dig axfr mein.domain” zu geben (gültig nur in lokal Netz).

Vielen Danken für ihre Hilfe,

rhino64


#2

Es gibt dazu einige Hinweise an [bug]32791[/bug], evtl. hilft dir das ja…


#3

Vielen Danken für die Hinweise die nützlich waren. Ich habe einige Bemerkungen über diese Änderungen:
1) Die Erläuterung der Variable «dns/fakeroot» nicht ganz klar für mich
This setting controls name resolution for non-locally defined DNS zones and is relevant only if no DNS forwarders have been set.
If the option is activated, no external servers will be used, so that only names from the local zones (among them the host itself)
can be resolved. If the variable is deactivated or unset, the standard DNS root servers are used for name resolution.
ich musste die Werte «no» in die Variable einsetzen um die Erlösung den Namen zu haben. Ohne Werte in die Webseite (ich dachte dass
das «deactivated» oder «unset» bedeutet) funktioniert die Erlösung nicht.
2) In dem Reiter «system services», kann man nicht den «univention-bind-proxy» wiederaufstellen (restart).

Meine zweite Frage war über die DNS Zonen verschieben (zone transfer). Die Datei «named.conf.proxy» enthalt diese Befehle:
options {
directory “/var/cache/bind”;
allow-query { any; };
allow-recursion { localhost; 10.0.0.0/8; 169.254.0.0/16; 172.16.0.0/12; 192.168.0.0/16; fc00::/7; fe80::/10; localnets; };
allow-query-cache { localhost; 10.0.0.0/8; 169.254.0.0/16; 172.16.0.0/12; 192.168.0.0/16; fc00::/7; fe80::/10; localnets; };
allow-transfer { any; };
listen-on-v6 { any; };
};

Man kann denn die Zonen in alle Netzwerke erhalten. Das ist ein bisschen zuviel und ich möchte gern nur für einige Netzwerke
limitieren. Ist es möglich?


#4

Die erste Frage verstehe ich nicht, glaube ich zumindest. UCR Variablen werden immer auf true/false oder yes/no gesetzt. Wenn das bei dir funktioniert ist das doch okay?!

univention-bind-proxy gibt es glaube ich nicht mehr wenn man Samba 4 einsetzt. Du solltest aber einfach “bind9” neu starten können.

Für die “allow…” Konfiguraiton gibt zwei beim mir mind. die beiden UCR Variablen dns/allow/query/cache und dns/allow/query
Sonst schau auch mal in die SDB: sdb.univention.de/1298