DHCP-Subnet wird beim NetzwerkImport nicht angelegt

german

#1

Hallo zusammen

Wir haben einen UCS-Master 4.1-4 (Multi-Server-Umgebung) errata350 mit UCS@School 4.1 R2 v8 und Samba4

Folgende Schritte wurden durchgeführt:

  • neue Schule mit create_ou (create_ou HANSA dchansa01 dchansa01v) hinzugefügt
  • Netzwerk mit import_networks hinzugefügt, dabei tritt folgender Fehler auf:

[quote]infile is : network.csv
verify ou for school nr HANSA
generate network 192.168.118.0/24
iprange: 192.168.118.10-192.168.118.250
defaultrouter: 192.168.118.1
nameserver: 192.168.118.3
netbiosserver: 192.168.118.3
creating object cn=hansa-192.168.118.0,cn=networks,ou=HANSA,dc=ssvaffo,dc=local
setting default router
ERROR: Unable to set policy for dhcp subnet because it does not exist: cn=192.168.118.0,cn=hansa,cn=dhcp,ou=HANSA,dc=ssvaffo,dc=local
setting netbios server
ERROR: Unable to set policy for dhcp subnet because it does not exist: cn=192.168.118.0,cn=hansa,cn=dhcp,ou=HANSA,dc=ssvaffo,dc=local
setting nameserver
ERROR: Unable to set policy for dhcp subnet because it does not exist: cn=192.168.118.0,cn=hansa,cn=dhcp,ou=HANSA,dc=ssvaffo,dc=local[/quote]

Das Netzwerk wird angelegt, das DHCP-Subnet dazu und die Policies nicht.
Legt man das DHCP-Subnet über die UMC an und importiert dann das Netzwerk, werden die Policies angelegt.

Der Import von Netzwerken auf diesem Master in den vorher angelegten OU’s (noch mit UCS@School 4.1 R2 v4) funktionierte.

Ein Test auf einem jungfräulich installierten Master (4.1-4 (Multi-Server-Umgebung) errata350 mit UCS@School 4.1 R2 v8 und Samba4) in unserer Testumgebung schlug ebenfalls mit o.g.Fehlermeldung fehl.

Ist dies ein Bug/Fehler in UCS@School?

Gruss
Detlef Stang


#2

Hallo Herr Stang,

wir konnten das von Ihnen geschilderte Verhalten nachvollziehen.

Das Problem lässt sich umgehen, indem der Schulserver (DC Slave) vor dem Aufruf von import_networks in die Domäne gejoined wird. Ist das Paket univention-dhcp installiert, so wird während des Joinvorgangs automatisch das fehlende DHCP-Subnet-Objekt im LDAP-Verzeichnis angelegt.
Alternativ legen sie das fehlende DHCP-Subnet-Objekt manuell über die UMC oder auf der Kommandozeile (via udm) an.

Ich habe für das Fehlverhalten den [bug]43103[/bug] angelegt, an dem Sie den weiteren Bearbeitungsstatus verfolgen können.

Viele Grüße

Sönke Schwardt-Krummrich