DHCP Server einrichten

german

#1

Hallo.

Was ist nötig, den DHCP Server einzurichten?
Ich habe bisher folgendes getan:

  • Pakete installiert (isc-dhcp-server und isc-dhcp-server-ldap)
  • Ein DHCP Objekt angelegt vom Typ DHCP Subnetz
  • Ein anderes Objekt vom Typ DHCP Rechner mit allen Angaben.

Aber der Rechner erhält keine IP Adresse! :frowning:

Was fehlt, bzw ist falsch?

Vielen Dank,
Christian


#2

Hallo Christian,

Bitte stattdessen die App “DHCP-Server” aus dem App Center installieren (oder alternativ das Paket “univention-dhcp” und die Joinskripte per “univention-run-join-scripts” ausführen).

Schönen Gruß,
Michael Grandjean


#3

Vielen Dank, das hat mich schon einmal einen grossen Schritt weitergebracht; leider ist dieses Vorgehen nicht in der Doku beschrieben (oder gucke ich an der falschen Stelle?).

Jetzt suche ich aktuell noch nach der EInstellung via DHCP das Standardgateway zu übermitteln.
Ich habe es leider erfolglos über “Richtlinie: DHCP Routing” versucht.

Auch hier: Für jeden Tip dankbar!

Viele Grüße,
Christian


#4

Hallo Christian,

read the fine manual:
docs.software-univention.de/de/ucs4.1.html

Installation dhcp:
docs.software-univention.de/hand … llsoftware

Konfiguration:
docs.software-univention.de/hand … :dhcp:dhcp

Kurzfassung Route anlegen:
udm -> Domäne -> Richtlinien -> Neu: policies/dhcp/routing

Kurzfassung Standardroute DHCP zuweisen:
udm -> Domäne -> DHCP -> “example.org:bearbeiten” -> Richtlinie: DHCP-Routing zuweisen

Gruß Lutz Willek


#5

Hallo Lutz,

habe das fine manual schon gelesen :slight_smile: VIelleicht zu oft, so dass ich einfach nur noch verwirrt bin :slight_smile:

Ich habe eine domänenweite RIchtlinie angelegt:
Name: DHCP default GW Typ: DHCP Routing Pfad: wtal.foomail.de/policies/dhcp/routing mit dem Wert des Gateways.
Danach eine Richtlinie in DHCP:wtal.foomail.de namens cn=gw-wtal01,cn=routing,cn=dhcp,cn=policies,dc=wtal,dc=foomail,dc=de auch mit dem Wert des Routers.

Aber es kommt einfach kein Router beim DHCP Client an :frowning:

Ein “udm policies/dhcp_routing list” zeigt auch beide EInträge an (sind wirklich beide nötig?).

Für jeden weiteren Tip dankbar!


#6

Fürs Archiv:

Habe die DHCP Einstellungen komplett gelöscht und neu angelegt, dann hat es auch mit dem Gateway geklappt…

Die Grundfunktionalität tut also jetzt, danke für alle Hinweise.

Eine Frage trotzdem noch:
Wo trage ich “Such Domains” (dhcp option domain-search) ein?

Danke und Gruss,
Christian