Cron <root@taurus> if [ -x /usr/sbin/univention-pkgdb-check

german

#1

Hi Forum,

ich bekomme im 15 min. Takt folgende Fehlermeldung per Mail:

check the postgres installation, the command 'python2.4 /usr/share/pyshared/univention/pkgdb.py --test-superuser' failed

Es handelt sich um ein UCS Version 2.3-1-2 als Slave installiert.

Logdatei postgresql-8.3-main.log:

2010-03-31 07:39:38 CEST [6495] LOG: connection received: host=[local] 2010-03-31 07:39:38 CEST [6495] FATAL: password authentication failed for user "pkgdbu"

Gruß

Marko Rappholz


#2

Hi Forum,

ich habe den Fehler gefunden, anscheint braucht der UCS die 7.4 Version von Postgres.

Ich habe die 8.3 Version gestopt und die 7.4 Version gestartet.

Ich frage mich bloß warum dann die Version 8.3 installiert wird.

Gruß

Rappholz


#3

Hallo,

im Zuge des Updates der Distributionsbasis von Debian Etch auf Debian Lenny wurde auch die Postgres-Version aktualisiert. Hinweise zur Migration von Postgres 7.4 Datenbanken auf die neue Version können in den Release-Notes und dem Changelog zu UCS 2.3 gefunden werden.

Vermutlich besteht auf dem System keine Datenbank und keine Benutzer unter Postgres 8.3 für die PKGDB. Diese müssten erstellt bzw. migriert werden.

Mit freundlichen Grüssen
Tobias Scherer