Connect to OX appsuite using internet domain

open-xchange

#1

I am using a local domain (XXXX.local) for my UCS servers and have done so for a long time. I have been using OX appsuite (serverURL ucs-ox1.XXXX.local) in a test environment so far (user@XXXX.local).
I now want to switch my e-mail and collaboration to a live OX appsuite and I run into a problem. My current e-mail is using the serverURL mail.XXXX.net and the e-mail is using the format user@XXXX.net.
I cannot find a way to point my current serverURL to my internal serverURL. The server shows an error every time I point my current address to the OX server.
I have registered a maildomain in OX Mail setup and my users are registered with both .local and .net addresses.

How can I configure OX appsuite so that my roadwarriors can use both the emClient/iOS/Android and and OX appsuite outside of the local domain.

I have always used a local domain behind the firewall and changing to an internet domain for my UCS servers would be a major undertaking that I rather not like to do


#2

You may config a split DNS (https://www.medic-daniel.de/microsoft-window-server/2012/10/split-dns-split-brain-fluch-oder-segen)

for that create an DNS ZONE for mail.XXXX.net on your internal UCS DNS Server with the local IP of the mail.XXXX.net and point your email clients to that FQDNS Name of the mail server

rg
Christian


#3

I have already done that, but that does not solve the problem. Actually there are two problems.

  1. The local FQDN is preset in the webgui and I cannot find where to change it.

  2. Using the emClient will generate a connection error using the internet URL. The IMAP inbound connection appear to work with the internet FQDN. However setting the outbound SMTP to the internet FQDN fails. I assume I have to add a SMTP relay for my internet FQDN. Question is: how do I do that?

I have found two settings in client-onboarding-mail.properties. can any of these be used to set the values i want
com.openexchange.client.onboarding.mail.imap.host=
com.openexchange.client.onboarding.mail.smtp.host=