Configure Virtual Host/ Access Owncloud From External Network


#1

I have just installed the virtual machine that comes with Owncloud. It’s all working fine. However, how can i configure the URL to access the application as currently i have to use an IP address.


#2

Maybe I dont understand this question but it looks like that this is more a question how you DNS is configured and how the virtual machine is integrated into your environment.
As an example:
Given that your infrastructure is based on MS Active-Directory your-ad.name.local you could install the UCS/ownCloud VM using the AD-member mode and (depending on your network setup) assign the DNS-name owncloud.your-ad.name.local.
This should allow you to access ownCloud at http://owncloud.your-ad.name.local/owncloud.


#3

Hi Ahrenke,

Thanks for the reply. I want to be able to access own cloud from outside our local network so with a domain like:

owncloud.xyzcompany.com

The DNS record externally has been setup, but we need to ensure the owncloud app is setup to bind to this dns name. We know this can be done via apache config files but i just can’t find them…


#4

You might want to look at the owncloud config file - “trusted domains”. No need to change the hostname / FQDN of the UCS for that.
You’ll only need to take care of proper NAT and Firewall rules.
However: You will get issues with the selfsigned certificate UCS uses per default.
You might need to change the certs for that.


#5

Do you happen to know where the config file is located. I have tried to use the find command but it only finds a few config.php in a directory like var/lib/docker but when i navigate to there it says permission denied…

thanks again


#6

Try /var/lib/univention-appcenter/apps/
You might need to login as root or use sudo to get there.

The file you’re looking for is config.php, probably in a folder called “config” or “conf”


#7

Excellent. I got it and solved the issue. i really appreciate your help.


#8

Excellent. Would you mind marking my answer as “Solution”?
Not for me or my ego, but others that search for solutions can then easily identify that this problem was actually solved - saves a lot of time scrolling through 1000s of threads, 90% of which never were marked as resolved…

Thanks!