Collabora Save "error"

collabora

#1

Hi,

I just installed Collabora and Nextcloud in a test environment, and it works quite well.

The only “problem” I encountered war, that clicking on the floppy disk symbol to Save, returns an error message (not enough access rights).
However, when the file is closed and opened again, I see the new version of the file - so saving was successful.

Any clue why the message appears?
People will click that icon and call us and I want to avoid that … :wink:

Thank,
Roland.


#2

Hi, is that the same setup as in your other thread? Or are both apps installed from the Univention App Center?


#3

No, different setup.

Both apps are from the App Center.

Actually it is UCS 4.2.0 - I’m updating right now, to see if it fixes the problem …


#4

Ok, all systems are now on 4.2.1 errata 133.
The problem is the same as before.

The Setup is:
One Master Server with Kopano installed (existed before).
One Member Server (new) with Nextcloud and Collabora. When I selected the Nextcloud App in the AppCenter it told me, that I should install univention-ldap-overlay-memberof before. Ok, so I thought that I installed the wrong UCS server type for that purpose. However, I installed the LDAP package first - as suggested - and then the App and it worked.
Then I installed Collabora, added the UCS cert and the Collabora App in Nextcloud.

When updating the member server, it told me, that a LDAP server on this machine is not supported. So I removed it:
univention-remove slapd

Then the update worked and the whole Nextcloud / Collabora setup still works as well, but there’s still the error message when clicking “Save”.


#5

Hi,

that error is cosmetic the file will be saved regardless of the error poping up - that error is solved with nextcloud 12

rg
Christian


#6

Yes, I know that it is cosmetic.
Thanks for letting me know, that it is a known bug.


#7

Hi,

FYI
I just updated nextcloud 11 to version 12 on UCS 4.2.1 through app-center and the error message on saving is gone

rg
Christian


#8

Hi,

thanks for the update!
I just tried it and can confirm that it works now.

Cheers,
Roland.