Change docker storage driver to 'overlay'

I trying update my little bit older UCS 4.4.1, but get error:

ERROR: The current docker storage driver is "overlay2".
       An update to UCS 4.2-2 is only possible if docker uses
       "overlay" as storage driver. To perform the update
       the docker storage driver has to be changed to "overlay".

       Please visit
       for more information.

So, I run ucr set docker/daemon/default/opts/storage-driver=‘overlay’
In /etc/default/docker is:

DOCKER_OPTS="--storage-driver=overlay --log-opt=max-file=4 --log-opt=max-size=10m --live-restore --log-driver=json-file --bip= "

But docker info still show overlay2

Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 0
Server Version: 18.09.7
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 
runc version: N/A
init version: v0.18.0 (expected: fec3683b971d9c3ef73f284f176672c44b448662)
Security Options:
  Profile: default
Kernel Version: 4.9.0-11-amd64
Operating System: Debian GNU/Linux 9 (stretch)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 5.832GiB
Name: ucs-dc1
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No swap limit support

Docker service restarted, server rebooted, but still stay on driver overlay2. And update UCS still not possible.

Any idea to fix?

1 Like

/etc/docker/daemon.json solved my problem.