Can't login into OX App Suite - Cannot find user with identifier “amo” in context 10. (USR-0015)

I made a new installation with Mailserver, OX App Suite and OX Connector.
I added a user and tried to login into the OX App Suite.
But I can’t, the error says Cannot find user with identifier “amo” in context 10. (USR-0015).
Can somebody help ?
The log says:

2023-07-07 11:14:30 INFO    Adding an accessprofile if like modifying it...
2023-07-07 11:14:30 INFO    Error while processing /var/lib/univention-appcenter/apps/ox-connector/data/listener/2023-07-07-10-02-39-837553.json
2023-07-07 11:14:30 WARNING Traceback (most recent call last):
2023-07-07 11:14:30 WARNING   File "/tmp/univention-ox-connector.listener_trigger", line 341, in run_on_files
2023-07-07 11:14:30 WARNING     function(obj)
2023-07-07 11:14:30 WARNING   File "/usr/lib/python3.9/site-packages/univention/ox/provisioning/", line 76, in run
2023-07-07 11:14:30 WARNING     create_accessprofile(obj)
2023-07-07 11:14:30 WARNING   File "/usr/lib/python3.9/site-packages/univention/ox/provisioning/", line 51, in create_accessprofile
2023-07-07 11:14:30 WARNING     modify_accessprofile(obj)
2023-07-07 11:14:30 WARNING   File "/usr/lib/python3.9/site-packages/univention/ox/provisioning/", line 55, in modify_accessprofile
2023-07-07 11:14:30 WARNING"Changing accessprofile {obj.dn}")
2023-07-07 11:14:30 WARNING AttributeError: 'TriggerObject' object has no attribute 'dn'
2023-07-07 11:14:30 INFO    This is consecutive error #678
2023-07-07 11:14:30 INFO    Sleeping for 0 sec
2023-07-07 11:14:30 INFO    Successfully processed 0 files during this run

The funny thing is, there is no folder with python 3.9 on the system (just 3.7).

Nobody ?
I did a installation 2 weeks ago with no problems. So there is something in the latest updates.

When I run listuser command it says;
/opt/open-xchange/sbin/listuser -c 10 -A oxadmin -P $(< /etc/ox-secrets/context10.secret)

Id Name Displayname Email qmax qused
2 oxadmin OX Admin -1

I made some more tests. Still the same problem. Also with an intranet domain.
We planned to use Univention. But now we cannot do this.
It seems that the problem came with one of the last updates.
This is very frustrating.
(Also be happy the speak in German).

had the same problem, fixed it by changing line 55 of /usr/lib/python3.9/site-packages/univention/ox/provisioning/ to"Changing accessprofile {obj}") and restarted the container.

Thank you, everything is running again.
Is it a (new) bug ? Where did you get this information from ?

not sure if thats a new bug, i was just evaluating it for a customer, had the same issue and did some debugging. seems like some other functions there would be affected too by the same issue (e.g. delete_accessprofile). would be nice if some UCS staff could shed some light here. the last code change to the ox-connector seems to be made a few months ago, so i guess it’s not a problem with the ox-connector but rather with some library being used in ox-connector and updated.

seems like someone added the same fix yesterday to the official repository

edit: seems like it was made 2 days ago but github just says “yesterday” for some reason