Cannot Upgrade to 4.2 (not yet available)


#1

Hi there,

when I’m trying to update to 4.2 I got the following message at the end of the process:

ERROR: The UCS 4.2 update is not yet available for UCS app appliances.
Please try to update your system to UCS 4.2 at a later point.
Error: Update aborted by pre-update script of release 4.2-0

How can I find out which APP is responsible for this message and get the upgrade to work?

Thanks a lot


UCS 4.2-2 upgrade fails
Upgrade von 4.1-5 auf 4.2 schlägt fehl
#2

Hi!

Can you paste the output of univention-app info here so we have a better idea what is running on your UCS and which App could possibly cause the message?

Best regards,
Michael


#3

Hello,

I assume you are running a branded virtual appliance of UCS, see the term [quote=“identt, post:1, topic:5979”]
not yet available for UCS app appliances
[/quote]

Branded virtual appliance currently still block the upgrade to UCS 4.2, because they are not yet available. Work is in progress on this topic. As mgrandje already asked, it would be good to know, which apps you have installed.


#4

Hi,

it is not a specific app that is causing the update to be blocked. We did not yet port the app appliance specific branding packages for UCS 4.2. It is unknown and untested what will happen if you update your UCS in that case. If you feel adventurous and make a snapshot before you start, you can try to uninstall the package univention-app-appliance and retry the update.


Univention Update from 4.2-4 errata421 auf UCS 4.3-1
#5

Here’s the list:

UCS: 4.1-4 errata410
App Center compatibility: 4
Installed: 
fetchmail=6.3.21 
iku-av-mail=1.0-4 
kopano-core=8.1.1.10-8.1-3 
kopano-webapp=3.2.0.335-19.1-2 
nextcloud=11.0.3-0 
self-service=1.0 
z-push-kopano=2.3.5
Upgradable: z-push-kopano

#6

Do I lose some important functionalities by uninstalling the univention-app-appliance package?


#7

Uninstalling the package should only remove the graphical adjustments for the UMC, bootsplash and so on. But as i said, i have never tested it, so you should make a backup or snapshot before you try it.