Cannot log into admin account after successful owncloud update

I successfully applied all the updates available for UCS ( 5.0-4 errata750) as well as Owncloud (10.12.1).
I ran into the issue of the trusted domains being cleared and managed to resolve that.
Everything appears to be working normally except that I can no longer log into my “Administrator” account in Owncloud. I can still log into UCS Administrator account that has the same password. All other accounts seem to be working just fine. When I tried resetting the password via SSH and occ, I get the message “Error while resetting password!”. I tried resetting the password from UCS Portal and that didn’t help either. Any ideas?

So solved this problem on my own. I am documenting the solution here in case it helps anyone else with troubleshooting.
Turns out it was simply a case of the LDAP DC IP address being incorrect. It was incorrect presumably because of restoring a backup clone of the VM and the IP address being re-assigned–not knowledgeable enough to understand why.
The reason the other accounts were all working is because years ago when I first set up this machine (without a clue that LDAP existed), I created the other accounts directly in Owncloud.

1 Like