Bluespice Mediawiki Search does not work

When I enter anything in the search bar and run it elastic search breaks with following in elasticsearch.log:
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [sortable_id] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

Any idea how to fix it? without working search wiki is useless.
Thank you

Hi, we have noticed that problem last week and have already fixed it. We have sent an update to Univention an wait for the approval by Univention. The new release should be available within the next days.

Great, looking forward to the update, Thank you

@RHeigl Any idea when this fix will be available? Can I get it somewhere else?

Thanks for the information. Waiting for the Update :slight_smile:

It is updated now. :slight_smile:

Thank you, though the search still does not work.

Hello,

The new image contains fixes for ExtendedSearch. It seems your situation requires manual operations.

Could you please run the following commands:
($your_container_name) should be replaced with your BlueSpice container name.

In your Univention server:

docker exec $your_container_name /usr/bin/php /var/www/bluespice/extensions/BlueSpiceExtendedSearch/maintenance/initBackends.php --quick

docker exec $your_container_name /usr/bin/php /var/www/bluespice/extensions/BlueSpiceExtendedSearch/maintenance/rebuildIndex.php --quick

finally
docker exec $your_container_name /usr/bin/php /var/www/bluespice/maintenance/runJobs.php

These steps will recreate Extended Search index.

Regards,
Gokhan

1 Like

Great this seems to resolve the problem. Thank you very much.

After the reindexing the data it was working ok.
Though my visual editing was not working, so I tried to reinstall the wiki.
After that I am back to the same issue with search.
The reindexing fixes it again

After I fixed the problem with the indexes the editor stopped working again …
Is there a way to reset it? Uninstalling is not clearing the existing data and configuration …

Hello,

It’s possible to restart parsoid service for VisualEditor.

Please login to your Univention server and then.

docker exec $your_container_name /etc/init.d/parsoid restart

Also, I have additional question.

How much RAM do you have in your Univention server?

Regards,
Gokhan

Thank you,
I have restarted the parsoid and it still did not work, I needed to additional entry to umc-access.conf. It seems to work ok now. Thank you very much for all the help.