"bind" in der UMC nicht neu starten

german

#1

Hallo,
was kann hier sein, wenn man den Dienst “bind” in der UMC nicht neu starten kann und dieser Fehler kommt:

Interner Modul-Fehler: Ein Fehler trat während des Ausführens des Befehls auf.
Fehlernachricht des Servers:
Die folgenden Dienste konnten nicht neugestartet werden: bind

Auf der Commandline funktioniert der Neustart.

Bitte um Hilfe.

Danke!!


#2

Hallo,

um welche UCS Version handelt es sich bei dem System?

ucr search version

Können Sie einmal den Befehl und die Ausgabe des Neustarts auf der Konsole posten sowie die Ausgabe von

ps waux | grep bind

Außerdem sollten Sie das Debug Level der UMC erhöhen,

ucr set umc/module/debug/level=4  umc/server/debug/level=4

die Aktion wiederholen und daraufhin die Logdateien unter

/var/log/univention/management-console-*

prüfen.

Mit freundlichen Grüßen
Tobias Scherer


#3

Hallo,

hier sind die Ausgaben:

ucr search version:[code]repository/mirror/version/end:
Highest version in the local repository
repository/mirror/version/start:
Lowest version for the local repository
update/umc/nextversion: true
The release update via UMC will stop after the update to the next version
version/erratalevel: 39
version/patchlevel: 1
Patchlevel of the UCS version
version/releasename: Horn-Lehe
Codename for UCS releases
version/security-patchlevel:
Security patchlevel of the UCS version

version/version: 3.0
Major version of UCS[/code]

bind restart:/etc/init.d/univention-bind restart Restarting bind9 daemon: . done.

ps waux | grep bind:root 1168 0.0 0.0 112 24 ? Ss Apr10 0:00 runsv univention-bind-samba4 root 1171 0.0 0.0 112 32 ? Ss Apr10 0:00 runsv univention-bind-proxy root 1172 0.0 0.0 112 24 ? Ss Apr10 0:00 runsv univention-bind bind 12758 0.1 0.3 195068 15596 ? Sl 16:20 0:00 /usr/sbin/named -c /etc/bind/named.conf -p 7777 -u bind -f bind 12776 0.2 0.3 129480 15268 ? Sl 16:20 0:00 /usr/sbin/named -c /etc/bind/named.conf.proxy -u bind -f root 12790 0.0 0.0 7552 852 pts/0 D+ 16:21 0:00 grep bind

management-console-web-server.log:19.04.12 16:24:07.769 MAIN ( INFO ) : UMCP_Dispatcher: check_queue: new request: 0x2f62b10 19.04.12 16:24:07.769 MAIN ( INFO ) : UMCP_Dispatcher: check_queue: normal request 19.04.12 16:24:07.769 MAIN ( INFO ) : SessionClient(0x2f628d0): sending request(133484544768441-4) 19.04.12 16:24:07.770 PROTOCOL ( INFO ) : Sending UMCP COMMAND REQUEST 133484544768441-4 19.04.12 16:24:08.251 PARSER ( INFO ) : UMCP RESPONSE 133484544768441-4 parsed successfully 19.04.12 16:24:08.251 PROTOCOL ( INFO ) : Received UMCP RESPONSE 133484544768441-4 19.04.12 16:24:08.251 MAIN ( INFO ) : SessionClient(0x2f628d0): got response(133484544768441-4): status=590 queue=0x2f67f80 19.04.12 16:24:08.251 MAIN ( INFO ) : CPCommand (::1:49544) got response(0x2f62c90) from queue(0x2f67f80): status=590 (sessionid="168a7bce-8ef8-4d80-a610-67dd0ba2c755") 19.04.12 16:24:08.251 MAIN ( PROCESS ) : CPCommand (::1:49544) response status code: 590 19.04.12 16:24:08.251 MAIN ( PROCESS ) : CPCommand (::1:49544) response message: Die folgenden Dienste konnten nicht neugestartet werden: bind

management-console-server.log:19.04.12 16:24:07.770 MAIN ( INFO ) : Starting new module process and passing new request to module services: 133484544768441-4 19.04.12 16:24:07.771 MAIN ( PROCESS ) : running: ['/usr/sbin/univention-management-console-module', '-m', 'services', '-s', '/var/run/univention-management-console/13026-1334845447771.socket', '-d', '4', '-l', 'de_DE.UTF-8'] 19.04.12 16:24:08.142 MAIN ( INFO ) : Connected to new module process 19.04.12 16:24:08.144 PROTOCOL ( INFO ) : Sending UMCP SET REQUEST 133484544814407-0 19.04.12 16:24:08.145 PROTOCOL ( INFO ) : Sending UMCP COMMAND REQUEST 133484544768441-4 19.04.12 16:24:08.147 PARSER ( INFO ) : UMCP RESPONSE 133484544814407-0 parsed successfully 19.04.12 16:24:08.147 PROTOCOL ( INFO ) : Received UMCP RESPONSE 133484544814407-0 19.04.12 16:24:08.147 MAIN ( PROCESS ) : The given response is invalid or not known 19.04.12 16:24:08.250 PARSER ( INFO ) : UMCP RESPONSE 133484544768441-4 parsed successfully 19.04.12 16:24:08.250 PROTOCOL ( INFO ) : Received UMCP RESPONSE 133484544768441-4

management-console-module-services.log:19.04.12 16:24:08.145 PROTOCOL ( INFO ) : Received UMCP SET REQUEST 133484544814407-0 19.04.12 16:24:08.145 MODULE ( INFO ) : Setting specified locale (de_DE.UTF-8) 19.04.12 16:24:08.145 MODULE ( INFO ) : Setting user LDAP DN uid=Administrator,cn=users,$ldap_base 19.04.12 16:24:08.145 PROTOCOL ( INFO ) : Sending UMCP RESPONSE 133484544814407-0 19.04.12 16:24:08.146 PARSER ( INFO ) : UMCP REQUEST 133484544768441-4 parsed successfully 19.04.12 16:24:08.146 MODULE ( INFO ) : Received request 133484544768441-4 19.04.12 16:24:08.146 PROTOCOL ( INFO ) : Received UMCP COMMAND REQUEST 133484544768441-4 19.04.12 16:24:08.146 MODULE ( INFO ) : Executing ['services/restart'] 19.04.12 16:24:08.146 MODULE ( ERROR ) : ['services/restart'] 19.04.12 16:24:08.249 PROTOCOL ( INFO ) : Sending UMCP RESPONSE 133484544768441-4


#4

Hallo,

hierbei handelt es sich vermutlich um das unter dem folgenden Link dokumentierte Verhalten:
[bug]26482[/bug]

Wir werden dies in einer der kommenden Versionen von UCS verbessern. Bis dahin sollte der Dienst als Workaround auf der Konsole gestartet und gestoppt werden.

Mit freundlichen Grüßen
Tobias Scherer


#5

Ist der Bug denn in der neuen Version behoben? Wäre nämlich unschön den Bug nochmal zu treffen. Das nervt.


#6

Hallo,

wie an [bug]26482[/bug] ersichtlich, wird dieses Verhalten in UCS 3.0-2 verbessert sein.

Mit freundlichen Grüßen
Tobias Scherer