Benno Mailarchiv update wird nicht angeboten

german
bennomailarchiv

#1

Hallo,
laut App Center news gibt es ein Update für das Benno Mail Archiv.

Meine Software-Aktualisierung erzählt mir allerdings dass Ich die neuesten Release Updates auf Grund des fehlenden Updates für das Benno Mailarchives nicht installieren kann.

Für Benno selbst wird mir aber kein Update angeboten. Es ist seit längerem auf der Version 2.2.6

Vielleicht kann mir ja jemand einen kleinen Hinweis geben wie man an dieses Update heran kommt?

root@ucs-6290:~# univention-app info
UCS: 4.2-4 errata421
App Center compatibility: 4
Installed: benno-mailarchiv=2.2.6 fetchmail=6.3.26
Upgradable:

Schöne Grüße
Matthias


#2

Huhu,

führen Sie bitte auf der Kommandozeile einmal univention-app update aus, bevor Sie noch mal univention-app info ausführen. Ich meine, dass die Kommandozeilen-App und die UMC evtl. unterschiedliche Speicherorte für die App-Indizes nutzen.

Gruß
mosu


#3

Hallo,
leider hat das auch kein Update zum Vorschein gebracht:

root@ucs-6290:~# univention-app update
Downloading "https://appcenter.software-univention.de/meta-inf/categories.ini"..                                                      .
Downloading "https://appcenter.software-univention.de/meta-inf/rating.ini"...
Downloading "https://appcenter.software-univention.de/meta-inf/license_types.ini                                                      "...
Downloading "https://appcenter.software-univention.de/meta-inf/ucs.ini"...
Downloading "https://appcenter.software-univention.de/meta-inf/4.2/index.json.gz                                                      "...
Downloading "https://appcenter.software-univention.de/meta-inf/4.2/index.json.gz                                                      .gpg"...
Downloading "https://appcenter.software-univention.de/meta-inf/4.2/all.tar.gpg".                                                      ..
Downloading "https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz                                                      "...
Downloading "https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz                                                      .gpg"...
Downloading "https://appcenter.software-univention.de/meta-inf/4.1/all.tar.gpg".                                                      ..
root@ucs-6290:~# univention-app info
UCS: 4.2-4 errata421
App Center compatibility: 4
Installed: benno-mailarchiv=2.2.6 fetchmail=6.3.26
Upgradable:

Kann es sein dass sich die Paketquellen mitlerweile geändert haben? bei mir steht da was von …2017…

root@ucs-6290:~# cat /etc/apt/sources.list.d/20_ucs-online-component.list
#Warning: This file is auto-generated and might be overwritten by
#         univention-config-registry.
#         Please edit the following file(s) instead:
#Warnung: Diese Datei wurde automatisch generiert und kann durch
#         univention-config-registry überschrieben werden.
#         Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):
#
#       /etc/univention/templates/files/etc/apt/sources.list.d/20_ucs-online-component.list
#

deb https://appcenter.software-univention.de/univention-repository/4.2/maintained/component/ benno-mailarchiv_20170619120638/all/
deb https://appcenter.software-univention.de/univention-repository/4.2/maintained/component/ benno-mailarchiv_20170619120638/amd64/
deb https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ benno-mailarchiv_20170619120638/all/
deb https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ benno-mailarchiv_20170619120638/amd64/
deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-4-errata/all/
deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-4-errata/amd64/
deb https://updates.software-univention.de/4.1/unmaintained/component/ 4.1-4-errata/all/
deb https://updates.software-univention.de/4.1/unmaintained/component/ 4.1-4-errata/amd64/
deb https://updates.software-univention.de/4.2/maintained/component/ 4.2-4-errata/all/

Schöne Grüße
Matthias


#4

Sie verwenden ja noch UCS 4.2. Die neue Benno-Version gibt’s nur für UCS 4.3. Wenn Sie das neuere Benno haben wollen, müssen Sie vorher Ihr UCS auf 4.3 aktualisieren.


#5

Henne Ei?
Ich kann Benno nicht aktualisieren weil ich nicht 4.3 habe.
Ich kann UCS nicht aktualisieren weil ich eine alte Bennoversion habe?
image


#6

Sieht momentan so aus, ja, leider. Sie haben da zwei Möglichkeiten:

  1. Wenden Sie sich an Univention und bitten Sie dort, dass ein Upgradepfad zur Verfügung gestellt wird. Die Benno-Komponente muss es halt in der gleichen Version auch für 4.3 geben, damit der Upgradeweg »UCS 4.2 mit Benno 2.2.x → UCS 4.3 mit Benno 2.2.x → UCS 4.3 mit Benno 2.4.x« funktioniert. Vielleicht weiß @botner dazu was — oder kann was rauskriegen?
  2. Benno deinstallieren, auf 4.3 aktualisieren, neue Benno-Version installieren.

Inwiefern 2. zu Datenverlust führt, kann ich nicht sagen.

Gruß
mosu


#7

Hallo,

die neue Version ist eine Docker App. Das bedeutet, dass die Software in einem Docker-Container läuft. Die alte Version hat das nicht getan.

Docker Apps können grundsätzlich auf allen UCS-Versionen betrieben werden. Wir haben aber momentan noch ein Problem mit Docker Apps aus UCS 4.3, die auch auf UCS 4.2 verfügbar sein sollen. Wir werden diese Apps aber baldmöglichst freischalten. Ab diesem Zeitpunkt kann man auch die neue Version von Benno Mailarchiv installieren.

Ein Update von der alten Version auf die neue ist aber noch einmal ein anderes Thema. Das geht in der Regel nicht so leicht. Daher wird das App Center dieses Update gar nicht erst anzeigen. Nicht, bevor nicht der Hersteller einen manuellen Migrationsplan verlinkt, den man dann befolgen kann. So jedenfalls ist es beispielsweise bei der App “Horde” gelaufen. Sobald dieses Dokument existiert, ist der Weg dann recht einfach und geht wieder über das App Center.

Weil auch ich nicht weiß, wie sich Benno Mailarchiv bei Deinstallation und Neuinstallation verhält, wäre das aus meiner Sicht zum jetzigen Zeitpunkt nicht empfehlenswert.

Viele Grüße
Dirk Wiesenthal


#8

Das ist derzeit (leider) der einzig mögliche Weg.
Wir haben hierfür im Wiki eine Anleitung erstellt.

Gruß,
Martin Werthmöller