BareOS install fails - uninstall as well

bareos

#1

Hiya,
yet another UCS system:
Tried to install BareOS on this system - which failed due to “half installed” packages: bareos, bareos-client, bareos-filedaemon.
Could not uninstall via the web-interface, so I had to remove it via CLI and apt-get.

Apparently it was removed thoroughly, as I also had to confirm deletion if the PostgreSQL DB.

Nevertheless: Trying to install it resulted in another “half” installation.
“Side-Effect”: The BareOS repository disappears as well - meaning I can’t even install / reinstall or uninstall anymore, until I copy the repo-data from another system (Where the install ran smoothly actually)

===

A few hours later:
I’m getting there … slowly.
99% up and running now.

The issues:
Software installed because bareos-fd couldn’t start.
Cause: Somewhere down in history, bareos seems to have been installed before … wanting to mount an NFS drive!

Gave bareos-fd the mount point. One step futher: Director couldn’t start : no database anymore.
Manually created a new db, re-installed all packages: OK.

Last topic not working:
Although the bareos checkbox for the “device” is there an can be selected: No autoconfigured client etc.

What script triggers this?

===

It’s a new day, a new dawn…
After digging through the BareOS documentation, I found out that the creation of autogenerated files is something which is included in newer BareOS versions.
Although I still don’t know, what exactly initiates this command - it works now.

Cheers
JK


#3

So … the resolution:

  1. check if there are any configs within the UCR regarding bareos - if yes: get rid of those that might cause trouble.
    (NFS mounts!!!)
  2. If you want to reinstall, make sure all prerequisites are met. (NFS Mounts - once again!)
  3. Stick to the documentation - and to give praise where it is due - bareos does an excellent job there!
  4. Avoid doing stuff like this after a hard days work. That’ll save you a ****load of work and headaches…