Authentisierungsfehler: Der UMC-Server hat auf die Authentis

german

#1

Hallo,

leider kann ich mich nach einer Neuinstallation des UCS nicht an der UMC anmelden.

[code] Patchlevel of the UCS version
Categories: system-base

version/releasename: hornbeam
Codename for UCS releases
Categories: system-base

version/security-patchlevel: 0
Security patchlevel of the UCS version
Categories: system-base

version/version: 2.3
Major version of UCS
Categories: system-base[/code]

Ich bekomme folgende Meldung:

Authentisierungsfehler: Der UMC-Server hat auf die Authentisierungsanfrage nicht geantwortet

ps waux | grep univention-management-console-server zeigt mir das der UCM-Server läuft.

root 4282 0.0 0.0 108 32 ? Ss 16:39 0:00 runsv univention-management-console-server root 7517 0.0 5.7 26056 14700 ? S 16:40 0:00 /usr/bin/python2.4 /usr/sbin/univention-management-console-server -n -d 1 -l de_DE.UTF-8 root 15724 0.0 0.2 3012 704 pts/1 D+ 18:44 0:00 grep univention-management-console-server

/etc/init.d/univention-management-console-server restart

gibt folgendes aus:

timeout: finish: univention-management-console-server: (pid 16099) 7732s, normally down ...done.

Im management-console-server.log stehen diese Einträge:

30.06.10 15:42:55 DEBUG_INIT 30.06.10 15:43:03 DEBUG_INIT 30.06.10 15:44:24 DEBUG_INIT 30.06.10 16:16:23 DEBUG_INIT 26.04.04 16:40:14 DEBUG_INIT 26.04.04 18:49:09 DEBUG_INIT

und im management-console-web.log steht:

26.04.04 18:40:21 DEBUG_INIT 26.04.04 18:40:21 ADMIN ( ERROR ) : univention-console-frontend.py: specified locale is not available (cmdline: de) UNIVENTION_DEBUG_BEGIN : uldap.__open host=univention.ucs.domain.local port=389 base=dc=ucs,dc=domain,dc=local 26.04.04 18:40:21 LDAP ( ERROR ) : ldapconn: unable to get ldap connection UNIVENTION_DEBUG_END : uldap.__open host=univention.ucs.domain.local port=389 base=dc=ucs,dc=domain,dc=local UNIVENTION_DEBUG_BEGIN : uldap.__open host=univention.ucs.domain.local port=389 base=dc=ucs,dc=domain,dc=local 26.04.04 18:40:21 ADMIN ( WARN ) : univention-console-frontend.py: sock: new connection 26.04.04 18:43:07 ADMIN ( WARN ) : univention-console-frontend.py: sock: new connection 26.04.04 18:43:07 ADMIN ( ERROR ) : Client: Setting up SSL configuration failed: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')] 26.04.04 18:43:07 ADMIN ( ERROR ) : Client: Communication will not be encrypted! UNIVENTION_DEBUG_END : uldap.__open host=univention.ucs.domain.local port=389 base=dc=ucs,dc=domain,dc=local 26.04.04 18:51:42 ADMIN ( ERROR ) : EXCEPTION: timeout 26.04.04 18:51:42 ADMIN ( ERROR ) : Traceback (most recent call last): File "/usr/share/univention-management-console/frontend/univention-console-frontend.py", line 333, in main raise Exception( 'timeout' ) # timeout Exception: timeout

Versuche ich den die Webseite des UDM zu laden kommt ebenfalls:

The LDAP server could not be contacted. Please try again later

Was muß ich noch ändern, damit ich auf die UDM und die UDC zugreifen kann?

Gruß Nixdorf


#2

Hallo nixdorf,

am besten machst du ein Update auf die Letzt UCS version.

mit dem Befehl:

univention-updater net

Achtung bei UCS 2.2 dort muss man --updateto 2.2-3 angeben sonst macht er ein Update auf 2.3 und dann geht Scalix nicht mehr.

Du muss diesen Befehl dirkt auf der Tastatur eingeben die am Server steckt bzw. auf der sogenannten Console 0.

Über ssh empfehle ich das nicht.

Backup vorher machen falls möglich sonst kann es eventuell sein das nichts / gewisse Sachen nicht mehr gehen.

LG
Franz


#3

Hallo,

ich habe univention auf einem esxi installiert, von daher kann ich schlecht eine Tastatur an den Rechner anschließen. Ich hatte univention-updater net schon mal per ssh ausprobiert, ich bin darauf in diesem Forum gestoßen. Aber anschließend wurde mir nicht mal mehr der Loginprompt von der UDM und UDC angezeigt.

Wie mache ich jetzt am besten den Update auf einem esxi?

Und der Befehl lautet: univention-updater net --updateto 2.2-3 richtig?

Gruß Nixdorf


#4

Hallo nixdorf,

dem ersten Posting entnehme ich, das der LDAP Serverdienst nicht läuft, dieser sollte mittels “/etc/init.d/slapd start” gestartet werden.

Wie genau sind Sie bei Ihrem Updateversuch vorgegangen. Die Versionsinformationen im ersten Posting zeigen, dass Sie ein UCS 2.3 System haben. Haben Sie bei einem Updatevorgang die Variable zum Ignorieren der ssh Sitzung gesetzt? update22/ignoressh oder update23/ignoressh
Welche Möglichkeiten haben Sie aktuell auf das System zuzugreifen?

Mit freundlichen Grüssen
Tobias Scherer


#5

Hallo,

ein /etc/init.d/slapd restart scheint problemlos durchzulaufen. Wo logged denn der slapd? Oder muß man noch den loglevel hochdrehen? Der steht derzeit auf 0. Im syslog erscheint noch:

Apr 28 18:48:15 univention univention-directory-listener: start_tls: Connect error

Im UDM kommt immer noch die Meldung:

The LDAP server could not be contacted. Please try again later.

pstree zeigt folgendes:

 ├─slapd───4*[{slapd}]

Im Moment habe ich gerade frisch neu installiert. Bei meinem Updateversuch auf dem System davor, hatte ich den Updateversuch in einer ssh-Sitzung gestartet. Die Sache mit den Einträgen update22/ignoressh muste ich noch ändern bevor ich univention-updater net ausführen konnte. Die Installation lief aber auch nicht glatt durch. Danach wurden mir aber die Webseiten der UDM sowie der UDC nicht mehr angezeigt. Ich hatte dann das System noch mal neu installiert.

Momentan kann ich per ssh und mit sphere auf den Univention-Server zugreifen.

Vielen Dank für die Hilfe bis jetzt…

Gruß Nixdorf


#6

also wenn Sie den Befehl über Sphere starten geht es dann?

univention-updater net

über SSH Updaten habe ich einmal versucht seit dem vermeide ich das so gut es geht denn ständig neuaufsetzen bei einem Abbruch der ssh Verbindung ist nicht mein Ding :wink:

LG
Franz


#7

Hallo,

um Abbrüche durch Unterbrechungen der Netzwerkverbindung bei Updates per ssh zu vermeiden, kann das Programm “screen” verwendet werden.

Welche Systemrolle haben Sie installiert, gab es währen der Installation Meldungen über Probleme oder wurden in der Datei “/var/log/installation.log” Meldungen gelogged?

Mit freundlichen Grüssen
Tobias Scherer


#8

Hallo,

so ich habe jetzt noch mal den update mit univention-updatet net in der Konsole gestartet, die ich mit Strg+Alt+F1 aufgerufen habe.

Leider ist es wieder zu Fehlermeldungen gekommen. Ich habe mal das updater.log mit angefügt.
updater.log (372 KB)


#9

also ich hab schon ein paar Fehler gesehen leider sind mir diese jetzt nicht geläufig aber Sie sind ja hier in guten Händen.
LG
Franz


#10

Hallo,

im updater.log ist, wie schon in einem der vorigen Beiträge zu sehen, das es Probleme mit der verschlüsselten LDAP Verbindung gibt. Evtl. sind die Zertifikate auf dem System nicht gültig. Dies kann unter Umständen durch falsche Zeiteinstellungen hervorgerufen werden. Das Zertifikat ist erst ab einem bestimmten Zeitpunkt gültig. Wenn die Systemzeit dieses Datum noch nicht erreicht hat, wird das Zertifikat als ungültig verworfen. Hinweise zu falschen Zeiteinstellungen finden sich auch in der updater.log:

tar: ./postinst: Zeitstempel 2010-01-07 16:23:35 liegt 179366839.42378916 Sekunden in der Zukunft.

Können Sie die Zeiteinstellungen korrigieren und das Update erneut durchführen? Danach sollte auch die weiter oben beschriebene Meldung nach dem Neustart des slapd nicht mehr auftreten:

[quote=“nixdorf”]Code:
Apr 28 18:48:15 univention univention-directory-listener: start_tls: Connect error[/quote]

Mit freundlichen Grüssen
Tobias Scherer


#11

Hallo,

das mit der Systemzeit war ein guter Tip. Die habe ich jetzt geändert. Mit dern Certifikaten gibt es glaube ich nicht mehr die Probleme.

univention-updater net konnte ich jetzt aber immer nicht starten, ich sollte dpkg --configure -a ausführen.

Dort sind dann aber wieder Fehlermeldungen aufgetreten. (Siehe Bildschirmfoto im Anhang) Auch das updater.log habe ich noch mal mit angehängt.

pstree zeigt folgendes: zeigt den ldap-prozess an.

Rufe ich die UDM auf kommt leider immer noch:

The LDAP server could not be contacted. Please try again later.



updater.log (376 KB)


#12

Hallo,

leider habe ich immer noch dieses Problem, weiß da evtl. noch wer was ich da machen kann?

Gruß Nixdorf


#13

Hallo,

wie ist denn der aktuelle Status des Systems? Sind noch unvollständige Paketupdates vorhanden? Sind evtl. Debian Paketsourcen eingetragen und Pakete aus diesem Repository installiert? Gab es evtl. schon bei der Installation Probleme? Sind neben der Installation und den Updates Arbeiten am System vorgenommen worden?

Die Erhöhung des Loglevel vom LDAP Server sollte auch weitere Informationen liefern. Dazu kann folgende UCR Variable gesetzt und der SLAPD neugestartet werden:

ucr set ldap/debug/level=stats
/etc/init.de/slapd restart

Der SLAPD schreibt dann Informationen nach /var/log/syslog .

Mit freundlichen Grüssen
Tobias Scherer


#14

Hallo,

ich habe den UCS jetzt noch mal auf einen separaten Server installiert. Jetzt hat alles auf Anhieb geklappt.

Noch mal vielen Dank für die Hilfe…

Gruß Nixdorf