Authentication issues with Z-Push using Outlook App on Android/Apple

Hello everyone,

we are using Univention for quite some time now and we are really happy with how it works.

Usually I am able to fix my issues through searching this forum or reading the documentation, but for this one, I need some more help.

My current UCS Version is: 4.4-2
The Z-Push for Kopano Version is 2.4.5

To break the issue down: A new user is unable to receive E-Mails in their Outlook App.
“Older” users (like 2 months ago) still work fine and can connect normally and receive their E-Mails.

I already checked the logs and stumbled across something weird. All those new Clients which are trying to connect have a # in front of their name for some reason.

31/10/2019 07:26:25 [ 8253] [ INFO] [#a.haettig] AuthenticationRequiredException: Access denied. Please send authorisation information - code: 0 - file: /usr/share/z-push/index.php:56
31/10/2019 07:26:25 [ 8253] [ INFO] [#a.haettig] User-agent: 'unknown'
31/10/2019 07:26:25 [ 8253] [FATAL] [#a.haettig] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
31/10/2019 07:26:25 [ 8253] [ INFO] [#a.haettig] cmd='Options' memory='1.56 MiB/2.00 MiB' time='0.02s' devType='Outlook' devId='XXX' getUser='a.haettig' from='XXXX' idle='0s' version='2.4.5+0-0' method='OPTIONS' httpcode='401'

It might be because of a Univention update or a Z-Push update. I am really unsure. I looked through the log files and also the permissions but no matter what I choose, it fails at this state. I also looked through some log files and the z-push configuration files but was unable to track down this weird # .

Kind Regards

Pascal Schwarz

Hi @pschwarz,

I have to prefix my answer with the hint that at least in the past the Outlook app for android/ios did not directly talk to the server, but routed all connections to a man in the middle (which then obviously also has to know about your password). At least in my test connections from the app still showed a different ip, then the one my device actually has.

I have just tried this with a test user and for me everything works (can login, sync and send mails). there was an advanced settings screen during account could it be that the # snuck in there?


Funny how you dismiss the possibility that an update of the app could be the culprit :wink:

1 Like

@pschwarz: Yes, One of the reasons I would not use Outlook App is because of that. Why not use the native iOS or other ActiveSync apps (e.g. “Nine”) for Android?


1 Like

Interesting point. I didn’t thought about that yet.

I rechecked everything and couldn’t find anything.

Another good point. It might be an issue with the App. And indeed. I tried @pro4567 's suggestion and it did work.

Thanks for the help and the fast responses! Really appreciated.

Kind Regards

Pascal Schwarz