Assign DHCP Server to specific NIC

Hey All,

Just have a question regarding the setup of DHCP Server for UCS. Currently I have the UCS deployed as a VM in a testing environment. I have given it two NICs, one for use to the outside world and the internet, the other for use only with other guest VMs. I would like to specifically set up the DHCP Server on the interface facing the VMs.

I can’t seem to find an option where I assign a DHCP Server to a NIC. Does anybody know how to assign a DHCP Server to operate/listen on a specific NIC?

Here is my current configuration, ethn0s3 should be the interface used by the DHCP Server. ethn0s8 is the interface which is used to connect to our router/internet (Which works great)

DHCP Settings:
2019-02-12%2008_07_33-Window
2019-02-12%2008_07_18-Window

Network Settings:
2019-02-12%2008_08_04-Window

Networks:
2019-02-12%2008_10_40-Window

Any help would be appreciated.

Thank you,

Hi,

afaik there is no such setting like “bind to NIC” in UCS-DHCP. The dhcpd in UCS determines it’s services by the subnets you define.

So if an interface is configured for network 192.168.0.222 and you define a dhcp subnet of 192.168.0.0/24 dhcpd will deliver services to the NIC with the IP 192.168.0.222.

If there is no subnet definition for your second NICH dhcpd will not serve any requests coming from this interface.

/CV

Hey Christian,

Thank you for the information, that helps clear things up. I was just checking my configuration and I still can’t get my clients get an IP Address from the DHCP server. I checked to make sure that the DHCP subnet, Network, and Interface address were all on the same subnet, which they are: 11.1.11.0/24. I even made a policy in the subnet options to allow unknown hosts to get a DHCP lease. The DHCP Server Service is also running.

If I statically assign an IP to one of the hosts on this network they can communicate with the UCS enp0s3 without a problem. I just can’t seem to get them to take an IP Address from the DHCP server.

Below are my configuration settings:

Network Settings:
enp0s3 Interface
Type: ethernet
Static IP: 11.1.11.1/24

2019-02-15%2008_28_20-

Networks:
Test Network
11.1.11.0/24
11.1.11.1 to 11.1.11.254
DHCP Preferences: Workstations

intranet%20-%20Univention%20Management%20Console

DHCP:

intranet%20-%20Univention%20Management%20Console
intranet%20-%20Univention%20Management%20Console intranet%20-%20Univention%20Management%20Console

I must still be missing something, maybe something simple. Any continued help would be appreciated.

Thank you,

Hey All,

I think I figured it out. I had to create the subnet within the foxtest.intranet dhcp service object in the dhcp settings and then set that service to be used in the “Networks” settings for that network. Since the IP of my enp0s3 interface was within that subnet, the dhcp server handed out the correct ip.

Before, I had configured a separate dhcp service object with its own subnet, but it seems as though you can define multiple subnets within one dhcp service object . When would it be applicable to have two separate dhcp service objects each with thier own dhcp server and subnet objects?

Thank you,

1 Like

In case anyone else had this issue, some screenshots of the pages that I adjusted:

intranet%20-%20Univention%20Management%20Console intranet%20-%20Univention%20Management%20Console

Thank you!

Hello,

Did not work. I did exactly as described: 1 interface for each subnet, I created a network in the domain with the interface subnet and created a new subnet in the DHCP service, all in the same subnet.

I restarted the servers and it still didn’t work. I am using v4.4-5 errata 652. I have a dc-master and dc-backup and all have the settings replicated normally.

Any suggestions as to what may have gone wrong?

I found out what the mistake was. The DHCP server name within the DHCP service MUST be the name of the dc-master, otherwise DHCP does not work.

It just changed to the name of the dc-master and it worked super smooth.

Thx