App Center doesn't work in UCS Docker container


#1

Hello,

I have my desktop PC (distro: Ubuntu 14.04.3 LTS, kernel: 3.19.0-28-generic) as the Docker host, mostly for development and testing purposes. I pulled the latest official UCS master image from the Docker Hub. The installation was smooth. I upgraded UCS to the latest stable release and updated the packages in the UMC successfully.

My first problem is that for some reason I can’t access the App Center in UMC. When I tried to open the App Center, I got an error message telling me to install Docker. So I ran univention-install docker.io in the CLI of the container and ensured it is running (quite funny having Docker running in Docker container, I didn’t know it’s possible). Still I can’t open the App Center - it is now giving me different error message:

[quote]Could not fulfill the request.

Server error message:

The command has failed: Could not query App Center: <urlopen error [Errno -2] Name or service not known>[/quote]

I tried to reboot the UCS but it didn’t help.

The second problem is that I can’t activate the UCS license. I always get this error message after trying the activation:

Any help appreciated!


#2

Hi,

Please try to import the license from the command line:

univention-license-import /path/to/license.ldif

run this command to verify:

univention-license-check

After that, please reload the Web interface UMC.

Have a look at the logs for more details if you are having more problems. There is a section on “Checking log files for relevant messages” in this SDB article:

sdb.univention.de/content/18/172 … -fail.html


#3

Thanks, Orrego. From the logs I found that the DNS isn’t working. I’ll try to fix it and will report the results here.