Anmeldund als ADMIN nach Update nicht mehr möglich

german

#1

Hallo Forum … da ich neu hier bin möge man mir die etwas unbeholfene Fragestellung verzeihen :wink: … jedenfalls habe ich versucht meinen Testserver auf die aktuellste Version “upzudaten” … dies ist mit
manuellem Eingriff dann auch gelungen … leider ist nun die Anmeldung nur mehr als root möglich (beim Basis) da er mir als Administrator was erzählt davon, dass die Anmeldung weniger als 10 sek. gedauert
hat …

Fehler - so zirka:
/usr/sbin/univention-findserver.sh: not found
rsh: getadrrinfo: Name or service not known

Bei der Uni-Konsole (Webinterface) lässt er mich aber dann als Admin anmelden … hat jemand eine Idee für mich bitte … Herzlichen Dank.


#2

Hallo und herzlich willkommen,

vielleicht zuerst mal die Frage: was genau ist denn passiert?

[ul]
[li]Was war denn der Testserver für eine Version, und auf welche Version wurde das Update versucht?[/li]
[li]vielleicht ein paar Überblicksangaben über die Struktur (welche Relation/Rolle hat der betreffende Server zur UCS-Domain, und wie ist deren Versionsstand des DC? oder ist es ein einzelner DC?)[/li]
[li]Wie wurde das Update gemacht (über das Webinterface, oder als Root angemeldet mit univention-upgrade etc.)[/li]
[li]Was heißt “mit manuellem Eingriff”? Was ist beim Updaten fehlgeschlagen, und wie wurde eingegriffen?[/li]
[li]Wichtig (und manchmal ausschlaggebend) welche zusätzlichen Dienste/Komponenten (z.B. CMS, Groupware, irgendwas aus dem AppCenter) trägt der betreffende Server? Meist müssen für solche integrierte Anwendungen beim Update die Anleitungen der jeweiligen Hersteller zusätzlich befolgt werden.[/li][/ul]

Im zweiten Schritt kann man dann anschauen, wie der jetzige Stand ist, also welche Anmeldung nicht geht und warum. Der Fehler “Anmeldung hat weniger als 10 Sekunden gedauert” klingt als wenn die Anmeldung selbst (LDAP basiert) funktioniert, aber irgendwas fehlt, was für eine (KDE-)Nutzersitzung benötigt wird. Ging denn das vorher?

Grüße
Frank Greif.


#3

dke für die rasche Antwort:

der Server macht - bis auf die Standard-Config noch gar nichts, da ich gerade am Anfang stehe mit dem “testen” … Der Server steht aktuell alleine auf weiter Flur
Das Update von Version 3.1.0 auf 3.1.1 - c139 war offensichtlich der Grund … zuerst hat das System das Update immer abgebrochen (angemeldet als Administrator) … als ich das Ding
dann mal rebooted hab und mich als root angemeldet hab, hat er auf einmal eine aktualisierung auf KDE 4 gemeldet … und auch durchgeführt … tja und genau seither geht meiner Meinung nach
die Anmeldung als “Administrator” nicht mehr … also root aber sehr wohl

Ich hoffe das hilft etwas weiter. Dke


#4

Was steht in
[ul]
[li] /var/log/univention/upgrade.log[/li]
[li] $HOME/.xsesion-errors vom Administrator[/li][/ul]

Und ich würde mal im gdm noch mal KDE4 als Sitzung auswählen und dann versuchen mich als Administrator anzumelden.