Anmeldedauer [Windows 7 64-Bit]

german

#1

Wir haben Windows-7-PC in die Domäne aufgenommen, die Domänen-Anmeldung an diesen PCs dauert ungewöhnlich lange.

Auszug aus log.smdb:

[2010/07/26 11:28:09, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(555) _netr_ServerAuthenticate2: netlogon_creds_server_check failed. Rejecting auth request from client TEST1 machine account TEST1$ [2010/07/26 11:33:14, 0] lib/util_sock.c:read_socket_with_timeout(939)

Kann dies vielleicht mit der Schreibweise zusammenhängen, denn in der UDM-Ansicht “Rechner” erscheint dieser in Kleinbuchstaben (“test1”)?

Verwendete UCS-Version: 2.3-2
Security-Patchlevel: 4


#2

Hallo,

haben Sie die in folgendem SDB Artikel Dokumentierten Schritte durchgeführt? http://sdb.univention.de/1102
Ist auf dem Windows7 Client der korrekte WINS Server eingetragen?
Wurde auf dem Sambaserver Winbind und/oder Wins konfiguriert, läuft dort der NSCD? Welche Systemrolle hat der Sambaserver?

ucr search winbind
ucr search wins
ps waux | grep nscd
ucr search role

Es könnte sich um das in diesem Eintrag in unserem Bug Tracking System beschriebene Verhalten handeln:
https://forge.univention.org/bugzilla/show_bug.cgi?id=17821

In diesem Fall kann auf Memberservern dieser Befehl ausgeführt werden:

net rpc join member

oder auf bspw. einem DC Master oder DC Backup:

net rpc join 

Mit freundlichen Grüssen
Tobias Scherer


#3

Ja.

Ja.

  1. Wins ist standardmäßig lt. Dokumentation aktiviert
  2. Winbind ist nicht konfiguriert, da nur die UCS-Domäne im Netzwerk vorhanden ist.
  3. Der NSCD läuft, die Überwachung erfolgt per Univention-Nagios und hat bisher keine Ausfälle angezeigt.
  4. Systemrolle: DC Master

Bei WinXP-Clients, welche in die UCS-Domäne gejoint wurden, tritt diese Verzögerung und die dazugehörige Meldung in der log.smbd-Datei nicht auf.

“hostname” auf WinXP-Rechnern zeigt den Rechnernamen in Klein-, auf Win7-PC in Großbuchstaben an.

(siehe auch hier)


#4

Hallo,

Benutzen Sie Servergespeicherte Profile mit den Standardeinstellungen oder davon abweichend?
Werden Logonscripte verwendet, wenn ja wo liegen diese und was wird dort ausgeführt?

Haben Sie die in dem erwähnten Foreneintrag verlinkte Lösung ausprobiert?
http://blog.bigsmoke.us/2010/03/17/fixing-extremely-slow-domain-logon-windows-7

Run gpedit.msc. Go to computer configuration. Go to Administrative templates. Go to System. Go to User profiles. Enable “Set maximum wait time for the network if a user has a roaming user profile or remote home directory” and set to 0 seconds

Mit freundlichen Grüssen
Tobias Scherer


#5

Es kommen keine servergespeicherten Profile bzw. Remotestammverzeichnisse zum Einsatz:

ucr get samba/profilepath local

ucr get samba/profileserver local

Es werden Logon-Skripte verwendet, diese liegen in der NETLOGON-Freigabe und enthalten nur “net use”-Befehle ohne irgendwelche Besonderheiten (z.B. “ifmember”-Abfragen o.ä.)

Die Anmeldung von in der Domäne aufgenommenen Windows-XP-Rechnern funktioniert tadellos und wirft keinerlei Fehlermeldungen aus (siehe Start-Post).

EDIT:

Wir haben herausgefunden, dass die Fehlermeldung aus dem Start-Post nicht unbedingt dem Verhalten zuzuordnen ist, da diese in der log.smdb jeweils nur beim ersten Anmelden am Tag erscheint. Bei späteren Anmeldungen erscheint diese Meldung nicht, jedoch erhalten wir andere Einträge in der “auth.log”, und zwar bei jeder Anmeldung:



#6

Tritt das Problem auf jeden Windows 7 Client auf bzw. mit jedem Benutzer?
Bzw. was passiert, wenn man bei einem Benutzer ein falsches Passwort eingibt?? Erscheint der Fehler sofort, dass ein falsches Passwort eingegeben wurde oder dauert dies auch seine Zeit??

Samba debuglevel auf 2 drehen und mitschauen, ob es bestimmte Aktionen gibt, wo er länger benötigt…

Lg


#7

Hallo,

ich habe dazu einen Eintrag in unserem Bug Tracking System angelegt, den Sie unter folgendem Link einsehen können:
https://forge.univention.org/bugzilla/show_bug.cgi?id=19560
Wir werden dieses Verhalten überprüfen.

Mit freundlichen Grüssen
Tobias Scherer