Angelegte Freigabe nicht sichtbar

german

#1

Hallo,

ich habe einen Share und Export über das Webfrontend angelegt. Der Mount via NFSv3 funktioniert, der Share ist jedoch nirgendwo auffindbar.
Ich bin Linux Neueinsteiger und muss mich noch orientieren, für Tipps bin ich also dankbar!

Das Kommando udm shares/share list zeigt mir auf dem DC und dem Fileserver alle von mir angelegten Shares.
Im Log /var/log/univention/listener.log finde ich keine Auffälligkeiten. Den Loglevel habe ich auf 4 erhöht und den Listner auf dem Fileserver neugestartet. Ich bekomme zwar eine sehr detailierte Ausgabe aber nichts was deutlich auf einen Fehler hinweist.

Vieleicht schaue ich nach dem Share an der falschen Stelle. Zuerst hatte ich es mit \fileserver01 versucht aber dort bekam ich kein Ergebnis. Der ist via CIFS nicht erreichbar.
Der Versuch mit \Sub.domain.tld zeigt mit nur die Shares netlogon und sysvol.

Gibt es eine Möglichkeit mit Bordmitteln aus dem UCS die Funktion des Shares zu testen? Ich nutze Windows 7 und Windows 8 als auch Linux. Alle nicht in der Domain. Ich authentifiziere mich also separat.

Ich habe im Forum und über mehrere Suchmaschinen gesucht aber leider keine passende Lösung gefunden.
Einige Lösungsvorschläge führen zwar zu einer Ausgabe, die ist für mich aber nichtssagend oder zeigt genau das erwartete Resultat. Nur der Share ist eben nicht sichtbar!
Vielen Dank für Tipps.

Mit freundlichen Grüßen

Hendrik


#2

Hallo,

ich schätze Sie beziehen sich auf die Windows Netzwerkumgebung wenn Sie sagen dass der Share “nirgendwo auffindbar” ist?

In der UMC gibt es eine Option “Freigabe wird in der Windows-Netzwerkumgebung angezeigt”, die müsste natürlich gesetzt sein damit der Share angezeigt wird (Sie können auch gerne die Ausgabe von udm shares/share list posten) .
Unabhängig davon sollten Sie den Share aber immer direkt aufrufen (\servername\sharename) oder z.B. per “smbclient” öffnen können (smbclient //servername/sharename -U domain+benutzername).

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,

ja, ich meine Windows-Shares. Den Share finde ich nirgendwo. Ein Versuch sich via SMB direkt mit dem Fileserver zu verbinden schlägt fehl.
Ich bekomme also beim Aufruf von \fileserver01 im Windows-Explorer kein leeres Fenster sondern eine Fehlermeldung dass der Server via SMB nicht erreichbar ist.
Ihrer Antwort entnehme ich, dass das so nicht sein sollte.

Die Option “Freigabe wird in der Windows-Netzwerkumgebung angezeigt” habe ich aktiviert bzw. Versuchsweise deaktiviert. Beides führt nicht zum Erfolg.

Ich werde heute Abend nochmal schauen ob ich da möglicherweise etwas vergessen habe (muss ich irgendwas separat installieren oder aktivieren?).

Im Folgenden die Ausgabe des Befehls udm shares/share list

[code]DN: cn=profiles,cn=shares,dc=sub,dc=domain,dc=tld
ARG: None
sambaDirectorySecurityMode: 0777
owner: 0
sambaName: profiles
sambaValidUsers: None
sambaCreateMode: 0744
group: 0
sambaForceCreateMode: 00
printablename: profiles (fileserver01.sub.domain.tld)
root_squash: 1
sambaHideUnreadable: 0
sambaBlockSize: None
writeable: 1
sambaSecurityMode: 0777
sambaForceSecurityMode: 00
sambaMSDFSRoot: 0
sambaStrictLocking: Auto
sambaDirectoryMode: 0755
sambaBlockingLocks: 1
name: profiles
sambaCscPolicy: disable
sambaFakeOplocks: 0
sambaNtAclSupport: 1
sync: async
sambaInheritOwner: 0
sambaPostexec: None
sambaHideFiles: None
sambaForceDirectoryMode: 00
sambaBrowseable: 1
sambaDosFilemode: 0
sambaInheritAcls: 1
sambaPreexec: None
sambaWriteList: None
sambaForceGroup: None
sambaInheritPermissions: 0
sambaVFSObjects: None
sambaForceUser: None
sambaOplocks: 1
sambaWriteable: 1
host: fileserver01.sub.domain.tld
path: /userdata/profiles/
sambaLocking: 1
sambaInvalidUsers: None
subtree_checking: 0
nfs_hosts: 10.0.0.0/24
sambaPublic: 0
directorymode: 0755
sambaForceDirectorySecurityMode: 00
sambaLevel2Oplocks: 1

DN: cn=documents,cn=shares,dc=sub,dc=domain,dc=tld
ARG: None
sambaDirectorySecurityMode: 0777
owner: 0
sambaName: documents
sambaValidUsers: None
sambaCreateMode: 0744
group: 0
sambaForceCreateMode: 00
printablename: documents (fileserver01.sub.domain.tld)
root_squash: 1
sambaHideUnreadable: 0
sambaBlockSize: None
writeable: 1
sambaSecurityMode: 0777
sambaForceSecurityMode: 00
sambaMSDFSRoot: 0
sambaStrictLocking: Auto
sambaDirectoryMode: 0755
sambaBlockingLocks: 1
name: documents
sambaCscPolicy: manual
sambaFakeOplocks: 0
sambaNtAclSupport: 1
sync: async
sambaInheritOwner: 0
sambaPostexec: None
sambaHideFiles: None
sambaForceDirectoryMode: 00
sambaBrowseable: 1
sambaDosFilemode: 0
sambaInheritAcls: 1
sambaPreexec: None
sambaWriteList: None
sambaForceGroup: None
sambaInheritPermissions: 0
sambaVFSObjects: None
sambaForceUser: None
sambaOplocks: 1
sambaWriteable: 1
host: fileserver01.sub.domain.tld
path: /userdata/documents
sambaLocking: 1
sambaInvalidUsers: None
subtree_checking: 0
nfs_hosts: 10.0.0.0/24
sambaPublic: 0
directorymode: 0755
sambaForceDirectorySecurityMode: 00
sambaLevel2Oplocks: 1

DN: cn=commonfiles,cn=shares,dc=sub,dc=domain,dc=tld
ARG: None
sambaDirectorySecurityMode: 0777
owner: 0
sambaName: commonfiles
sambaValidUsers: None
sambaCreateMode: 0744
group: 0
sambaForceCreateMode: 00
printablename: commonfiles (fileserver02.sub.domain.tld)
root_squash: 1
sambaHideUnreadable: 0
sambaBlockSize: None
writeable: 1
sambaSecurityMode: 0777
sambaForceSecurityMode: 00
sambaMSDFSRoot: 0
sambaStrictLocking: Auto
sambaDirectoryMode: 0755
sambaBlockingLocks: 1
name: commonfiles
sambaCscPolicy: manual
sambaFakeOplocks: 0
sambaNtAclSupport: 1
sync: sync
sambaInheritOwner: 0
sambaPostexec: None
sambaHideFiles: None
sambaForceDirectoryMode: 00
sambaBrowseable: 1
sambaDosFilemode: 0
sambaInheritAcls: 1
sambaPreexec: None
sambaWriteList: None
sambaForceGroup: None
sambaInheritPermissions: 0
sambaVFSObjects: None
sambaForceUser: None
sambaOplocks: 1
sambaWriteable: 1
host: fileserver02.sub.domain.tld
path: /commonfiles
sambaLocking: 1
sambaInvalidUsers: None
subtree_checking: 0
nfs_hosts: 10.0.0.0/24
sambaPublic: 0
directorymode: 0755
sambaForceDirectorySecurityMode: 00
sambaLevel2Oplocks: 1

DN: cn=userdata,cn=shares,dc=sub,dc=domain,dc=tld
ARG: None
sambaDirectorySecurityMode: 0777
owner: 0
sambaName: userdata
sambaValidUsers: None
sambaCreateMode: 0744
group: 0
sambaForceCreateMode: 00
printablename: userdata (fileserver01.sub.domain.tld)
sambaHideUnreadable: 0
sambaBlockSize: None
sambaSecurityMode: 0777
sambaForceSecurityMode: 00
sambaMSDFSRoot: 0
sambaStrictLocking: Auto
sambaDirectoryMode: 0755
sambaBlockingLocks: 1
name: userdata
sambaCscPolicy: manual
sambaFakeOplocks: 0
sambaNtAclSupport: 1
sambaInheritOwner: 0
sambaPostexec: None
sambaHideFiles: None
sambaForceDirectoryMode: 00
sambaBrowseable: 1
sambaDosFilemode: 0
sambaInheritAcls: 1
sambaPreexec: None
sambaWriteList: None
sambaForceGroup: None
sambaInheritPermissions: 0
sambaVFSObjects: None
sambaForceUser: None
sambaOplocks: 1
sambaWriteable: 1
host: fileserver01.sub.domain.tld
path: /userdata/
sambaLocking: 1
sambaInvalidUsers: None
sambaPublic: 0
directorymode: 0755
sambaForceDirectorySecurityMode: 00
sambaLevel2Oplocks: 1[/code]
Namen habe ich verändert.

Vielen Dank für die Hilfe!

Mit freundlichen Grüßen

Hendrik Dreyer


#4

Hallo,

[quote=“hendrix3er”]Ich bekomme also beim Aufruf von \fileserver01 im Windows-Explorer kein leeres Fenster sondern eine Fehlermeldung dass der Server via SMB nicht erreichbar ist.
Ihrer Antwort entnehme ich, dass das so nicht sein sollte.[/quote]
das klingt sehr danach das Samba nicht läuft oder nicht installiert ist. Bitte prüfen Sie über das App Center auf “fileserver01” dass dort Samba korrekt installiert ist und alle Join-Scripte ausgeführt wurden (die UMC sollte anzeigen wenn das nicht der Fall ist). Im “Systemdienste” Modul sollten Sie sehen können ob Samba läuft.

Mit freundlichen Grüßen
Janis Meybohm


#5

Hallo,

ich traue es mich gar nicht zu schreiben aber - Problem gelöst
Ich habe Samba nicht installiert. Ich war der meinung es sei mitinstalliert und habe daher einfach nicht nach dem einfachsten Problem gesucht.

Jetzt sehe ich allerdings die Freigabe Administrator welche unterordnet für Windows Profile enthält.
Da ich diese gar nicht brauche würde ich sie gerne entfernen, finde aber hier keine Möglichkeit dazu.
In der CLI suche ich offenbar an der falschen Stelle denn im Ordner /etc/samba finde ich keine Datei die eine solche Freigabe definiert.

Zusätzlich würde ich gerne NFSv4 Exports anlegen. Hierzu habe ich aber leider keine wirklich hilfreichen Informationen gefunden.
Unter diesem Link habe ich Informationen gefunden, kann aber den Export nicht mounten:
http://wiki.univention.de/index.php?title=NFS_with_UCS

Gibt es da eine kurze Info oder sollte ich hierzu einen eigenen Beitrag erstellen?

Vielen Dank!

Mit freundlichen Grüßen

Hendrik Dreyer


#6

Hallo,

[quote=“hendrix3er”]Jetzt sehe ich allerdings die Freigabe Administrator welche unterordnet für Windows Profile enthält.
Da ich diese gar nicht brauche würde ich sie gerne entfernen, finde aber hier keine Möglichkeit dazu.
In der CLI suche ich offenbar an der falschen Stelle denn im Ordner /etc/samba finde ich keine Datei die eine solche Freigabe definiert.[/quote]
ich bin nicht sicher ob ich das verstehe.
Standardmäßig legt UCS Verzeichnisse für Windows Profile im Heimatverzeichnis an (windows-profiles/…). Windows selbst erzeugt im angegebenen Profilpfad (abhängig von der Windows Version) ebenfalls unterverzeichnisse um die Profile unterschiedlicher Versionen voneinander zu trennen.

[quote=“hendrix3er”]Zusätzlich würde ich gerne NFSv4 Exports anlegen. Hierzu habe ich aber leider keine wirklich hilfreichen Informationen gefunden.
Unter diesem Link habe ich Informationen gefunden, kann aber den Export nicht mounten:
http://wiki.univention.de/index.php?title=NFS_with_UCS[/quote]
NFS exports werden seit UCS 3.2 standarmäßig auch per NFSv4 exportiert. Wenn Sie den Export nicht mounten können, müsste es dazu am Client und am Server meldungen geben die die Ursache eingrenzen.
Sie können dazu natürlich auch gerne einen neuen Thread auf machen um die Themen besser zu trennen.

Mit freundlichen Grüßen
Janis Meybohm


#7

Hallo,

ich sehe die Freigabe wie folgt:
\fileserver01\Administrator

Darunter befinden sich die Profilpfade für die jeweilige Windows-Version. Ich habe aber nicht nur keinen Windowsrechner in der Domäne, ich möchte auch die Freigabe nicht pauschal auf jedem Fileserver sehen.
In der UMC habe ich sie nicht erstellt und finde zumindest auf dem DC keine Einstellungen dazu. In der Registry des Fileservers habe ich aber noch nicht gesucht.

Für NFS öffne ich einen neuen Thread. Da habe ich wohl ein grundlegendes Verständnisproblem.
Wenn ich den Export in der UMC konfiguriere ohne weitere Einstellungen vorzunehmen wird ein NFSv3 Export erstellt.
Das sehe ich nicht nur unter /etc/exports auf dem Fileserver sonder jeder Linux client der sich im zugelassenen Netzewrk befindet hat Zugriff.
Wenn das Passwort dann noch übereinstimmt oder GID oder UID kann irgendeinsystem auf sämtliche Daten zugreifen.

Ich gehe eigentlich davon aus, dass Kerberos hier verhindert, dass ein Rechner oder User welcher der Domäne nicht bekannt ist sich auch nicht anmelden darf, also den Export nicht mounten kann.

Vielen Dank!

Mit freundlichen Grüßen

Hendrik Dreyer


#8

Hallo,

ich bin weiterhin nicht sicher ob ich das richtig verstehe.
Unter Samba hat die Freigabe “homes” eine Sonderstellung, diese Freigabe erlaubt dass Samba immer automatisch das Heimatverzeichnis des sich Anmeldenden Benutzers zur Verfügung stellt. Deaktivieren können Sie das auf dem Fileserver über die UCR Variable “samba/share/home” (mit anschließendem Samba Neustart).

Mit freundlichen Grüßen
Janis Meybohm


#9

Hallo,

vielen Dank noch einmal für die Hilfe. Es hat ein Weilchen gedauert aber ich habe es nun begriffen.
Es wird automatisch die Freigabe mir dem Namen des Benutzernamens erstellt wenn dieser angemeldet ist.
Diese Freigabe enthält den Profilpfad welcher auch, wenn nicht anders konfiguriert, die Dokumente des Benutzers enthält.

Ich habe bislang via GPO unter Windows immer einen Separaten Profilpfad erstellt welcher Unterordner der jeweiligen Benutzer entält sowie einen Pfad für die Dokumente des Benutzers.
Hierzu je eine Freigabe:
\Server\profiles%username%
\Server\documents%username%

Dies ist unter UCS bereits vorbereitet mit dem Unterschied, dass der Ordner des Benutzers vollständig als dedizierte Freigabe eingeblendet wird.

Mit freundlichen Grüßen

Hendrik Dreyer