After upgrade to ucs 4.2 root volume is mounting read only


#1

Hi,

after upgrading to the new 4.2 release the server mounts the root partition in read only, I think the problem is the expansion of te root partition in the past

here is a screenshot of my root layout

and fstab

annd uuid’s

does any one have a hint to me to resolv this ?

regards

Christian


#2

Try this command:
mount -t ext4 -o rw,remount -force /dev/sda5/vg_ucs-root /
and then reboot the machine.
This has worked many times for our ucs if it was read only.

regards
Pascalis


#3

You should additionally make sure that the volumes are not “full” - i.e. that there is enough space left.


#4

thanks for the hint but it didn’t work for me :frowning:

rg
Christian


#5

thanks - the volumes are about 50% used so there is enough space free i think

rg
Christian


#6

Hello externa1,

looks like the volume is always mounted with errors so it falls back to ro. You might start in recovery mode and try ‘fsck’.

kind regards


#7

thanks the filesystem is ok
some more info

i found some solutions about this error in the web relating to UUID’s so I changend my fstab for / from /dev/mapper/vg_ucs-root to UUID=8b47f126-80f5-40ab-b0b0-d9e1f4edb824
but that also did not solve this

rg
Christian


#8

Ok i found the problem,

it was the entry in fstab for disabling the MetaBlockCache as suggested in errata 166 for UCS4.1

https://errata.software-univention.de/ucs/4.1/166.html

after removing the no_mbcache entry in fstab its working now

But why ist this happening and how/should I disable mb caching anymore ?

rg
Christian