After install opsi Samba dosn´t work and join script 96univention-samba4.inst don´t run. exitcode 1


#1

Hello Community
i installed an UCS Server with connect to an windows Active directory.
all works fine… but after installation of opsi, samba doesn’t´t work and the message box says no permissions.

I spend many days for this Problem. I hope one can help my.

======== Join.log ================
RUNNING 96univention-samba4.inst
2018-09-04 14:12:31.660107458+02:00 (in joinscript_init)
ERROR: It is not possible to install a samba 4 domaincontroller
       into a samba 3 environment.
EXITCODE=1
RUNNING 97univention-s4-connector.inst
2018-09-04 14:12:32.310398923+02:00 (in joinscript_init)
04.09.18 14:12:32.852  DEBUG_INIT
UNIVENTION_DEBUG_BEGIN  : uldap.__open host=ucs-server02.fritzweg.local port=7389 base=dc=fritzweg,dc=local
UNIVENTION_DEBUG_END    : uldap.__open host=ucs-server02.fritzweg.local port=7389 base=dc=fritzweg,dc=local
ERROR: The domain is in AD Member Mode.
Not updating connector/s4/autostart
Setting connector/s4/listener/disabled
Restarting univention-directory-listener (via systemctl): univention-directory-listener.service.
EXITCODE=1
RUNNING 98univention-pkgdb-tools.inst
EXITCODE=already_executed
RUNNING 98univention-samba4-dns.inst
2018-09-04 14:12:38.314816239+02:00 (in joinscript_init)
Samba4 backend database not available yet, exiting joinscript 98univention-samba4-dns.
EXITCODE=1
RUNNING 99opsi4ucs.inst
EXITCODE=already_executed

Di 4. Sep 14:12:39 CEST 2018
univention-run-join-scripts finished
======== Join.log ================

[EDIT:]
I see the error massage “It is not possible to install a samba 4 domaincontroller
into a samba 3 environment.”

i Change teh settings and now i get “ERROR: The domain is in AD Member Mode, cannot join as DC.”

But the Samba shued be an member server as befor i installed the OPSI

Thanks


#2

Hi,

by default it appears to be correct so far. When you are running in AD member mode you can not install a directory server. This won’t work.

Could you please cut&paste the output of univention-app domain?

/CV


#3

Hello Christian,

result of the command is:

root@ucs-server01:~# univention-app domain
ucs-server01.fritzweg.local:
UCS: 4.2-4 errata500
App Center compatibility: 4
Installed: adconnector=11.0
Upgradable:

I have now a fresh install of UCS. I changed from samba to samba4
after that i get the following error msg in join.log

RUNNING 96univention-samba4.inst
2018-09-05 11:52:05.005686463+02:00 (in joinscript_init)
05.09.18 11:52:05.697 DEBUG_INIT
UNIVENTION_DEBUG_BEGIN : uldap.__open host=ucs-server01.fritzweg.local port=7389 base=dc=fritzweg,dc=local
UNIVENTION_DEBUG_END : uldap.__open host=ucs-server01.fritzweg.local port=7389 base=dc=fritzweg,dc=local
ERROR: The domain is in AD Member Mode, cannot join as DC.
EXITCODE=1
RUNNING 98univention-samba4-dns.inst
2018-09-05 11:52:05.752727422+02:00 (in joinscript_init)
Samba4 backend database not available yet, exiting joinscript 98univention-samba4-dns.
EXITCODE=1


#4

Hi,

exitcode 1 is normal behaviour of our joinscripts so far.

Do you see any issues or problems currently?

/CV