Activation of SuiteCRM appliance no email of ucs.license file

I’ve downloaded the UCS Virtualbox appliance image and successfully imported and ran through the installation.
I’m at the Activation of SuiteCRM Appliance where it is supposed to email you the ucs.license file. I’ve tried with browser connection in Firefox, Chrome and Edge browsers.

Is there a step I’m missing to have the file sent?

I’ve received the Univention Corporate Server onboarding email and the one for the forum user activation but nothing else in spam or junk mail folders that have a license file.

The onboarding email says "Great, you successfully installed and activated your installation of Univention Corporate Server (UCS). " but I’m stuck at the upload license file screen.

I’ve checked firewall settings (computer and router), browser settings and add ons.
I’ll check mx settings next - but I think should be fine since I recieved the other emails from Univention. Any suggestions would be appreciated!

Okay - I just tried a gmail address instead and it sent the file through. So assuming it was a mx pointer or something else.

Hello @Martinini,

welcome to Univention Help and thanks for your patience in receiving the activation email. Since the last request resulted in a delivered email there may have been an error either on our side issuing the activation key or on the delivery route.

I’ll send you a direct message for further questions in order to make sure the creation of the activation keys worked properly on our side.

Best regards,

Hello I have the same problem.
I use a gmail address and when i click in request activation, there is no reaction and no mail.
I have check the spam.
Can you help me.
Best regards