About SugarCRM Installation from App Center


#1

I am installed UCS_3.1-0-amd64.iso on my system. Install done perfectly. Everything working such as samba 4 (i tried to join domain and success) but when i try to install SugarCRM or anything else on App Center it gives me error like ;

3 errors occurred:
digitec-sugarcrm-web: No such package
digitec-sugarcrm-zip-ce: No such package
digitec-sugarcrm-master: No such package

On repository section i saw SugarCRM repos but on Status column it says “Not Found”

There is no network issue and no filter or something on my network.

Thanks.


#2

Hi,

please try to re-set the sugarCRM repository settings:

univention-add-app sugarcrm

please check the repository host afterwards and try to fetch information for the package:

host appcenter.software-univention.de apt-cache policy digitec-sugarcrm-master

you should also have a look at /etc/apt/sources.list.d/20_ucs-online-component.list - there could be hints leading to possible misconfiguration.

Mit freundlichen Grüßen,
Tim Petersen


#3

In /etc/apt/sources.list.d/20_ucs-online-component.list

there is error message like ;

[code]# An error occurred during the repository check. The error message:

Traceback (most recent call last):

File “”, line 13, in

File “/usr/lib/pymodules/python2.6/univention/updater/tools.py”, line 519, in init

self.ucr_reinit()

File “/usr/lib/pymodules/python2.6/univention/updater/tools.py”, line 575, in ucr_reinit

assert self.server.access(’/univention-repository/’)

File “/usr/lib/pymodules/python2.6/univention/updater/tools.py”, line 444, in access

raise ConfigurationError(uri, reason)

ConfigurationError: Configuration error: host is unresolvable

After fixing this issue, you should rewrite this file with the following command:

univention-config-registry commit /etc/apt/sources.list.d/20_ucs-online-component.list

#[/code]


#4

Hi,

please check the current settings for repository servers. You could get a short overview by executing the following command:

ucr search --brief repository

Please attach the output to your next answer, I will gladly have a look then.

Kind regards,
Tim Petersen


#5

ucr search --brief repository

Here is output;

local/repository: <empty> online/repository/clean: <empty> repository/mirror/architectures: <empty> repository/mirror/basepath: /var/lib/univention-repository repository/mirror/httpmethod: <empty> repository/mirror/port: <empty> repository/mirror/prefix: <empty> repository/mirror/recreate_packages: yes repository/mirror/server: <empty> repository/mirror/sources: <empty> repository/mirror/threads: 10 repository/mirror/version/end: <empty> repository/mirror/version/start: <empty> repository/mirror: false repository/online/architectures: <empty> repository/online/component/3.1-0-errata/description: Errata updates for UCS 3.1-0 repository/online/component/3.1-0-errata/version: 3.1 repository/online/component/3.1-0-errata: enabled repository/online/component/sugarcrm-errata/localmirror: false repository/online/component/sugarcrm-errata/parts: maintained repository/online/component/sugarcrm-errata/server: appcenter.software-univention.de repository/online/component/sugarcrm-errata/version: current repository/online/component/sugarcrm-errata: enabled repository/online/component/sugarcrm/localmirror: false repository/online/component/sugarcrm/parts: maintained repository/online/component/sugarcrm/server: appcenter.software-univention.de repository/online/component/sugarcrm/version: current repository/online/component/sugarcrm: enabled repository/online/errata/start: <empty> repository/online/hotfixes: no repository/online/httpmethod: <empty> repository/online/maintained: yes repository/online/port: 80 repository/online/prefix: <empty> repository/online/server: univention.test-dc.com repository/online/sources: <empty> repository/online/unmaintained: no repository/online: yes xen/repository: file:///var/lib/univention-server-cdrom


#6

Hi,

the problem seems to be the ucr variable repository/online/server.
In case of no existing local repository, the correct online server should be updates.software-univention.de:

ucr set repository/online/server="updates.software-univention.de"

It would be great if you can send us an Univention-Support-Info archive as described in sdb article #1182 in order to be able to check why this was set like that.

Kind regards,
Tim Petersen


#7

Thank you for your answer. My problem solved. Succesfully installed SugarCRM but i cant find where to login SugarCRM ?

When i go trough univention corporate server overview page there is nothing about SugarCRM.

It has just like ;

Welcome to Domaincontroller Master dc! :
Univention Management Console
Univention Nagios
Horde4 Webclient
Root certificate
Certificate revocation list
Univention
Univention forum
Univention documentation


#8

Hi,

please provide us an Univention-Support-Info archive as described at sdb articel #1182
We will be able to have a further look then.

Kind regards,
Tim Petersen


#9

Here is attachment as you describe.

edit admin: I downloaded and removed your attachement, because there could be sensible information in it - please use upload.univention.de next time, as described in the article. Thanks.


#10

Hi,

i suppose the packages could not be configured completely because of the trailing misconfiguration of the repository server and the tried installation.
Please try the following:

/usr/share/sugarcrm/install-sugarcrm.sh /usr/share/digitec/sbin/setup-sugarcrm-gui.sh a2ensite sugarcrm invoke-rc.d apache2 reload

Kind regards,
Tim Petersen


#11

Now its success. I can login with my.server.ip/sugarcrm

but now i cant login with any user.

When i check sugarcrm database on mysql , it has users table and it has my all users. But i cant login to sugarcrm.

Thanks.


#12

Hi,

have you tried the user Administrator? You have to enable the SugarCRM usage for any user within UMC.
Please see “Users” -> -> “SugarCRM” -> “Use SugarCRM”

Kind regards,
Tim Petersen


#13

Thank you for your all replies. I have found and working now.

Thank you for your business.