x-Bit in den Zugriffsrechten

german

#1

Hallo,

warum werden Dateien (vom Explorer über Samba-Freigabe) immer mit “+x” im Unix-Dateisystem erzeugt?

In den “Erweiterten Einstellungen/Erweiterte Sambarechte” habe ich für den “Dateimodus” das Zugriffsbit für Eigentümer und Gruppe gelöscht.
Für “andere” habe ich alle Bits gelöscht - da wird dann auch nichts gesetzt: “rwxrwx—”.

Die Freigabe liegt auf einem xfs-Volume ohne besondere Mount-Optionen.


#2

Huhu,

weil das x-Bit standardmäßig kontrolliert, ob das Ausführen-Recht an Windows-Clients übermittelt wird (wie also unter Linux auch). Wenn man z.B. einer auf einer Samba-Share liegenden .exe alle x-Bits wegnimmt, so darf man die Datei unter Windows nicht mehr ausführen.

Man kann das Ganze mit einer bestimmten Konfigurationsoption auch übersteuern; siehe Samba-Wiki.

Diese Option (acl allow execute always) ist unter Univention übrigens über eine UCR-Variable samba/acl/allow/execute/always konfigurierbar und standardmäßig an.

Meine Vermutung ist aber, dass von Windows-Seite aus schlicht immer »alle Rechte« angefordert werden bzw. keine explizite Einschränkung stattfindet, was Samba wiederum so umsetzt, dass auch das x-Bit gesetzt ist — es sei denn, man übersteuert das für eine Share mit den Datei-/Verzeichnismodi-Einstellungen.

Gruß
mosu