Wrong Version number of Member Server in DC - Upgrade 5.0 fails

Hi there,
I run a UCS 4.4.8 as DC an two UCS as KVM as standalone Server (DMZ, Proxy…).

While trying to upgrade to 5.0, it fails due tu wrong version of the member Server (the KVM ones).
It detects a very old version but in fact, the servers are all up to date on 4.4.8.

Why are these standalone Server registered as Member Server?
Why is the Version of these Servers not updated at the DC so the Upgrade fails?

Any help?
Can I correct the versions on the DC manualy?
Can I ignore these warning and override it?

Thanks a lot.
Andreas

What do you mean by standalone Server? Did you setup them as bases system or as member server? Execute ucr get server/role on your KVM servers to get the server role.

  • basesystem: The former are standalone, are not connected to your LDAP at all and only have local accounts. This role is no longer supported since UCS-5, but should not block the upgrade as these systems are not part of your domain and thus should not block the upgrade.
  • memberserver: The later are part of the domain and are connected to your LDAP environment. As KVM is no longer supported with UCS-5 this may be the underlying reason.

Afterwards check the local UCS version on you servers by running ucr search --brief ^version/ on them.

Compare these versions to udm computers/memberserver list | grep -e ^DN: -e operatingSystem on your Primary/Master: operatingSystemVersion should match those values. If not try to update them using udm computers/memberserver modify --dn … --set operatingSystemVersion=….

PS: It helps if you copy&paste the exact error message here or at least provide a screenshot.

Well thanx, the modification of the LDAP Entry did it and now the system is upgrading. Cross fingers. :wink:

OK, sorry, here comes the Error message maybe for other Users:

minimum_ucs_version_of_all_systems_in_domain:
The following hosts must be upgraded to UCS 4.4-8 first:
cn=ucs-appserver,cn=memberserver,cn=computers,dc=klixxa,dc=intranet: 4.3-3

Error: Update aborted by pre-update script of release 5.0-0

Starting univention-upgrade. Current UCS version is 4.4-8 errata1128

Both Systems are “domaincontroller_master”, well maybe that’s not a good idea? but worked quite well. I chose different Domains.
I wanted to separate the User-Base and LDAP

Both have the Version:
version/erratalevel: 1128
version/patchlevel: 8
version/releasename: Blumenthal
version/version: 4.4

Yes, KVM was uninstalled before except of libvirt. And PostgresSQL updated.

Maybe you can give a short hint, how I should have set up a Environment with:

  • DomainController master (internal Services, Samba, Nextcloud…)
  • Standalone Server (no connection to the internal LDAP) with own Userbase for external Nextcloud an other external services
  • Server with htproxy to deliver different Websites to different server.

Thanks for the quick and successful help. Univention is a really great system!

Andreas