Where does Nextcloud app are installed on UCS ? Trying to find Collabora Online folder so i can revert back to version 3.5.3

Hello can someone explain me where the Collabora Online apps is installed

In OCCWEB Console when im running this command
occ $ app:getpath richdocuments
it return me the path : /var/www/html/apps/richdocuments

and when i ssh to the server ive got this error
cd /var/www/html/apps/richdocuments
-bash: cd: /var/www/html/apps/richdocuments: No such file or directory

So where is it on the server i don’t understand

Im trying to find this because Collabora Online version 3.6.0 don’t work anymore and i would like to revert back to version 3.5.3 with this zip file


Thanks for your help !

Hello @support_ti,

the path you are looking for is inside the Nextcloud app, which is running in a Docker container. In order to access that path you need to go inside that container with univention-app shell nextcloud.

I don’t know the needed tools are available inside the Nextcloud Docker container to download the richdocuments archive you need. In case they are not:

  1. Obtain the container id for the Nextcloud container: docker ps and pick the one for Nextcloud.
  2. Copy the file from your UCS host inside the container: docker cp richdocuments.tar.gz <container id of nextcloud container>:<target directory inside container>

Disclaimer: I don’t know if it is the right approach to replace the files for the richdocuments plugin in Nextcloud with this procedure. And I don’t know the implications. I haven’t tested it.

I hope this helps anyway.

Best regards,

1 Like

Can you explain me how to find the docker for nextcloud ive tried this

root@cloud:/var/www/html# univention-app shell nextcloud
root@nextc-57258297:/# docker ps
bash: docker: command not found

Thanks !

Hello @support_ti,

with univention-app shell nextcloud you are already in the Docker container. Use this command to move around in the Nextcloud container.

I assume you refer to the copy step. This needs to be done on the UCS host. Leave the Docker container and on the UCS host, execute docker ps. Please beware the context. I wasn’t very clear on this, sorry.

Best regards,

Wow thanks a lot for your help it worked this is the step ive done to revert back to Collabora Online 3.5.3 and now it is working

1- In nexcloud active apps page disable the apps “Collabora Online” 3.6.0

2- In nexcloud disable apps page remove the apps “Collabora Online” 3.6.0

3- In ssh on the UCS server you need to find docker container id
root@cloud:/# docker ps
2fedffc6d0d7 docker.software-univention.de/collabora: “/bin/sh -c 'bash st…” 12 hours ago Up 12 hours>9980/tcp wonderful_brattain
d9c5ae57ed42 docker.software-univention.de/nextcloud:18.0.4-0 “/bin/sh -c /usr/sbi…” 21 hours ago Up 12 hours>80/tcp determined_shamir

4- Transfer the richdocuments.tar.gz to the UCS server with WinSCP. The file can be download here

5- Copy the gz file in the docker container - docker cp richdocuments.tar.gz :
root@cloud:~# docker cp richdocuments.tar.gz d9c5ae57ed42:/var/www/html/apps

6- Go inside nextcloud docker container
root@cloud:~# univention-app shell nextcloud

7- Extract the .gz file and give the same permission as other folder
root@nextc-57258297:/var/www/html/apps# tar zxvf richdocuments.tar.gz
root@nextc-57258297:/var/www/html/apps# chown -R www-data:nogroup richdocuments

8- Return in nexcloud apps page and enable the apps “Collabora Online” version 3.5.3

Collobara Online 3.5.3 work again

Thanks again for your precious help i learn alot with your help !

1 Like

Hello @support_ti,

thanks for your feedback. It’s great to hear that it worked out for you.

Best regards,

@support_ti and @gulden Very thanks for your great work here. It is working perfectly!